Bug 1161284

Summary: git dependency
Product: [Fedora] Fedora Reporter: Helmut K. C. Tessarek <tessarek>
Component: gettextAssignee: Daiki Ueno <dueno>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: rawhideCC: dueno, i18n-bugs, petersen, praiskup
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: gettext-0.19.8.1-7.fc26 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-01-26 12:21:26 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Helmut K. C. Tessarek 2014-11-06 20:18:25 UTC
Description of problem:

gettext-devel depends on git

Additional info:

Mail correspondence with Daiki Ueno:

> Can you please remove the git dependency for gettext-devel?
>
> This is supposed to be a development package (mainly include files).
> Since git on Fedora is very old and not updated reagularily, I tried to
> remove git (to compile my own git) and to my surprise I saw that
> gettext-devel depends on git.
>
> AFAIK this is the only *-devel package which depends on git.

Actually, it _was_ needed for autopoint (a developer script, like
autoconf or automake), when we used git as a compression method of
/usr/share/gettext/archive.dir.*.  Now that the default changed to
tar.xz, git shouldn't be necessary anymore.

> I truly believe this is a bug. Can you please fix this?

Could you please file a bug on bugzilla.redhat.com, so we don't forgot
to fix it on the next update?

Comment 1 Fedora Update System 2014-12-31 14:50:01 UTC
gettext-0.19.4-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/gettext-0.19.4-2.fc21

Comment 2 Helmut K. C. Tessarek 2014-12-31 16:57:06 UTC
Thanks for looking into this. Can you please generate an RPM for F20? 
There are still a lot of people using Fedora 20.

Comment 3 Fedora Update System 2015-01-03 19:09:18 UTC
gettext-0.19.4-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2015-01-05 01:42:07 UTC
gettext-0.18.3.2-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gettext-0.18.3.2-4.fc20

Comment 5 Fedora Update System 2015-01-17 05:35:50 UTC
gettext-0.18.3.2-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Pavel Raiskup 2017-01-26 11:50:03 UTC
Reopening because I think this was actually not fixed correctly.  Having
'%bcond_without git' implies '%{with git}' is still 1, thus the dependency
was not really removed.