Bug 1161469

Summary: perl-DBD-Firebird-1.18-1.fc22 FTBFS randomly: t/embed-80-event-ithreads.t fails: Parse errors: Bad plan.
Product: [Fedora] Fedora Reporter: Petr Pisar <ppisar>
Component: perl-DBD-FirebirdAssignee: Robert Scheck <redhat-bugzilla>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: redhat-bugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
URL: https://ppisar.fedorapeople.org/perl_rebuild/scratch/2014-11-06/index.xhtml#pperl-DBD-Firebird
Whiteboard:
Fixed In Version: perl-DBD-Firebird-1.20-1.el7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-04-03 12:24:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Petr Pisar 2014-11-07 08:07:17 UTC
perl-DBD-Firebird-1.18-1.fc22 fails to build in F22 sometimes due a failing test:

t/embed-80-event-ithreads.t   (Wstat: 0 Tests: 15 Failed: 0)
  Parse errors: Bad plan.  You planned 22 tests but ran 15.

Difference between last working and failing build root is:

Removed packages:
	audit-libs-2.4
	cpp-4.9.1
	gcc-4.9.1
	gcc-c++-4.9.1
	gdb-7.8
	glib2-2.42.0
	groff-base-1.22.2
	libgcc-4.9.1
	libgomp-4.9.1
	libstdc++-4.9.1
	libstdc++-devel-4.9.1
	perl-HTTP-Tiny-0.050
	perl-Pod-Perldoc-3.24
	perl-Pod-Usage-1.63
	perl-Thread-Queue-3.05
	systemd-216
	systemd-libs-216
	tzdata-2014h
Added packages:
	audit-libs-2.4.1
	cpp-4.9.2
	gcc-4.9.2
	gcc-c++-4.9.2
	gdb-7.8.1
	glib2-2.43.0
	libgcc-4.9.2
	libgomp-4.9.2
	libstdc++-4.9.2
	libstdc++-devel-4.9.2
	perl-Pod-Parser-1.62
	systemd-217
	systemd-libs-217
	tzdata-2014i

I cannot reproduce the failure, but running the test over and over reveals, the test dead-locks after some time:

$ I=0; while (prove -v -b t/embed-80-event-ithreads.t); do echo "$I"; I=$((I+1)); done
[...]
25
t/embed-80-event-ithreads.t .. 
1..22
ok 1 - Connected to the database
ok 2 - Table is 'TESTAF'
ok 3
ok 4
ok 5
ok 6
ok 7
ok 8
ok 9 - callback registered
ok 10 - thread created
ok 11 - thread joined
ok 12 - callback unregistered
ok 13
ok 14
ok 15 - create thread


This test number matches the bad-plan error, so there can be a hidden race or a bug.

Comment 1 Jaroslav Reznik 2015-03-03 16:28:41 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 2 Robert Scheck 2015-06-22 11:54:59 UTC
I think this is https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=719582

Comment 3 Fedora Update System 2015-06-22 17:04:08 UTC
perl-DBD-Firebird-1.20-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/perl-DBD-Firebird-1.20-1.fc22

Comment 4 Fedora Update System 2015-06-22 17:04:44 UTC
perl-DBD-Firebird-1.20-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/perl-DBD-Firebird-1.20-1.fc21

Comment 5 Fedora Update System 2015-06-22 17:05:07 UTC
perl-DBD-Firebird-1.20-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/perl-DBD-Firebird-1.20-1.fc20

Comment 6 Fedora Update System 2015-06-22 17:06:34 UTC
perl-DBD-Firebird-1.20-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/perl-DBD-Firebird-1.20-1.el7

Comment 7 Fedora Update System 2015-06-22 17:07:01 UTC
perl-DBD-Firebird-1.20-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/perl-DBD-Firebird-1.20-1.el6

Comment 8 Fedora Update System 2015-06-24 15:57:21 UTC
perl-DBD-Firebird-1.20-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2015-07-03 18:38:22 UTC
perl-DBD-Firebird-1.20-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-07-03 18:45:48 UTC
perl-DBD-Firebird-1.20-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-07-13 18:32:11 UTC
perl-DBD-Firebird-1.20-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-07-13 18:32:47 UTC
perl-DBD-Firebird-1.20-1.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.