Bug 1164448

Summary: Upstream moved for fonttools
Product: [Fedora] Fedora Reporter: Peter Oliver <mavit>
Component: fonttoolsAssignee: Parag Nemade <pnemade>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: rawhideCC: fonts-bugs, pnemade
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-11-27 13:35:40 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1162341    
Attachments:
Description Flags
Change upstream and update version none

Description Peter Oliver 2014-11-15 14:38:48 UTC
The upstream for fonttools has moved from http://sourceforge.net/projects/fonttools/ to https://github.com/behdad/fonttools.

Additionally, there is a verion 2.5 tagged on GitHub; the version currently in Fedora is 2.4.

Comment 1 Peter Oliver 2014-11-15 17:38:34 UTC
Created attachment 957840 [details]
Change upstream and update version

The attached patch worked for me.

Comment 2 Parag Nemade 2014-11-16 06:37:04 UTC
Thanks. I will apply this patch and build an update in master.

Comment 3 Parag Nemade 2014-11-16 07:45:15 UTC
I have committed your patch but I like to keep simple spec file hence changing your Source: changes to use released tarball. Also, looks like now package is noarch.

Comment 4 Peter Oliver 2014-11-16 10:29:47 UTC
Sorry, I notice that there was a typo in the new URL.  It should be "https://github.com/behdad/fonttools".

Comment 5 Parag Nemade 2014-11-16 10:52:49 UTC
Fixed all issues in fonttools-2.5-2.fc22 

Please test and report any issues. I will close this later on.