Bug 1164889

Summary: support TLS 1.1 and later
Product: [Fedora] Fedora Reporter: Stephen Gallagher <sgallagh>
Component: openldapAssignee: Jan Synacek <jsynacek>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 21CC: awilliam, extras-qa, jsynacek, jv+fedora, mreynolds, mruckman, phracek, rmeggins, robatino, sgallagh
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedBlocker
Fixed In Version: openldap-2.4.40-2.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1160466 Environment:
Last Closed: 2014-11-25 03:05:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1160466    
Bug Blocks: 1043129, 1160467, 1160468    

Description Stephen Gallagher 2014-11-17 19:30:53 UTC
+++ This bug was initially created as a clone of Bug #1160466 +++

Description of problem:
I don't believe tls_m.c supports TLS 1.1 and later.  This requires some additional NSS APIs.  You should be able to tell openldap to support TLS protocols > 1.0 with TLS_PROTOCOL_MIN

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Rich Megginson on 2014-11-04 16:41:22 EST ---

This needs to go into all versions of Fedora ASAP.  Should I clone this for all Fedora releases?

--- Additional comment from  on 2014-11-07 19:18:41 EST ---



--- Additional comment from Jan Synacek on 2014-11-10 03:41:35 EST ---

Mark, could you please submit the patch upstream and link the ITS to this bugzilla? Thanks!

--- Additional comment from  on 2014-11-12 15:29:21 EST ---



--- Additional comment from  on 2014-11-12 15:30:52 EST ---

(In reply to Jan Synacek from comment #3)
> Mark, could you please submit the patch upstream and link the ITS to this
> bugzilla? Thanks!

Jan,

The patch has been submitted to openldap:  ITS#7979

Thanks,
Mark

--- Additional comment from Jan Synacek on 2014-11-14 04:26:54 EST ---

Pushed:
http://pkgs.fedoraproject.org/cgit/openldap.git/commit/?id=4b2abac9db548c3ce7f44df72517eec50d68eefc

Mark, could you please verify that the functionality remains? I had to backport the upstream patch, the code in rawhide openldap is quite different...

--- Additional comment from  on 2014-11-14 10:29:38 EST ---

(In reply to Jan Synacek from comment #6)
> Pushed:
> http://pkgs.fedoraproject.org/cgit/openldap.git/commit/
> ?id=4b2abac9db548c3ce7f44df72517eec50d68eefc
> 
> Mark, could you please verify that the functionality remains? I had to
> backport the upstream patch, the code in rawhide openldap is quite
> different...

Jan, so there is no "pvers" table in rawhide?  Can I look at the internal repo?  If so, not sure how to(you can email me offline with the details)?

The rest of the patch, the important part, looks good.

Thanks,
Mark

Comment 1 Fedora Blocker Bugs Application 2014-11-17 19:34:08 UTC
Proposed as a Blocker for 21-final by Fedora user sgallagh using the blocker tracking app because:

 "* The Domain Controller must be capable of serving LDAPS (LDAP encrypted with SSL) over port 636. This should be validated by the use of the ldapsearch tool." (Currently proposed Final Criteria for Fedora Server)

Without this patch, FreeIPA in its default configuration cannot be accessed by any LDAP client using openldap with the NSS crypto library (which is how SSSD and ipa-client-install functions).

Comment 2 Mike Ruckman 2014-11-19 17:05:30 UTC
Discussed in 2014-11-19 blocker review meeting. This bug violates the final creterion for fedora server:  "The Domain Controller must be capable of serving LDAPS (LDAP encrypted with SSL) over port 636. This should be validated by the use of the ldapsearch tool."

Comment 4 Fedora Update System 2014-11-20 08:33:00 UTC
openldap-2.4.40-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/openldap-2.4.40-2.fc21

Comment 5 Fedora Update System 2014-11-22 20:21:59 UTC
Package openldap-2.4.40-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openldap-2.4.40-2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15613/openldap-2.4.40-2.fc21
then log in and leave karma (feedback).

Comment 6 Adam Williamson 2014-11-24 16:22:46 UTC
sgallagh says in bodhi:

"Confirmed by following the instructions at https://lists.fedoraproject.org/pipermail/server/2014-November/001582.html"

so we can mark as VERIFIED, I believe.

Comment 7 Fedora Update System 2014-11-25 03:05:50 UTC
openldap-2.4.40-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.