Bug 1165618

Summary: Malformed ipv6 DNS reverse lookup
Product: Red Hat Enterprise Linux 6 Reporter: Aleš Koval <als>
Component: squidAssignee: Luboš Uhliarik ✈ <luhliari>
Status: CLOSED ERRATA QA Contact: Ondřej Pták <optak>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.6CC: dkutalek, optak, psimerda, thozza
Target Milestone: rcKeywords: Patch
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: squid-3.1.10-33.el6 Doc Type: Bug Fix
Doc Text:
Previously, it was not possible to log host names. With this update, squid no longer sends malformed DNS PTR queries, and as a result, host names are logged as expected.
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-07-22 06:26:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Aleš Koval 2014-11-19 11:20:09 UTC
Squid send malformed PTR query for IPv6 address. This affects logging FQDN.

See http://bugs.squid-cache.org/show_bug.cgi?id=3215

Comment 2 Tomáš Hozza 🤓 2014-12-05 13:04:36 UTC
patch is in the upstream bug

Comment 5 Ondřej Pták 2015-06-18 21:57:46 UTC
If squid is configured to log fqdn, there should be hostname instead of host ip. With squid-3.1.10-29, there is correctly hostname displayed in log, but with previous version of squid reverse lookup failed an ip address was displayed instead.

squid.conf (part)
=================
log_fqdn on
logformat fdqn %>A %>Hs "%rm %ru"
access_log /var/log/squid/fdqn.log fdqn

squid-3.1.10-29.el6
===================
2620:52:0:1040:dad3:85ff:fe7e:6068 200 "GET http://[2620:52:0:10bb:21e:67ff:fe94:7c67]/ 

squid-3.1.23-9.el6
=================
some.host.redhat.com 200 "GET http://[2620:52:0:10bb:21e:67ff:fe94:7c67]/"

Comment 7 errata-xmlrpc 2015-07-22 06:26:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1314.html