Bug 1167083

Summary: [abrt] recoll: ole.py:40:byteOrder:IndexError: string index out of range
Product: [Fedora] Fedora Reporter: Koen <koen.schram>
Component: recollAssignee: Terje Røsten <terjeros>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 20CC: koen.schram, marwalk, terjeros
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
URL: https://retrace.fedoraproject.org/faf/reports/bthash/d729e6549525c55b3792f51765bbb8023697b272
Whiteboard: abrt_hash:ad7aea821d8d2a16a4b0610cd88c3aa9e2463a82
Fixed In Version: recoll-1.20.1-1.fc20 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-01-20 21:04:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
File: backtrace
none
File: environ none

Description Koen 2014-11-23 12:41:55 UTC
Version-Release number of selected component:
recoll-1.19.14p2-1.fc20

Additional info:
reporter:       libreport-2.2.3
cmdline:        python2 /usr/share/recoll/filters/xls-dump.py --dump-mode=canonical-xml --utf-8 --catch /tmp/rcltmpfFuUqab.xla
executable:     /usr/share/recoll/filters/xls-dump.py
kernel:         3.17.2-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            500

Truncated backtrace:
ole.py:40:byteOrder:IndexError: string index out of range

Traceback (most recent call last):
  File "/usr/share/recoll/filters/xls-dump.py", line 241, in <module>
    main()
  File "/usr/share/recoll/filters/xls-dump.py", line 234, in main
    dumper.dumpCanonicalXML()
  File "/usr/share/recoll/filters/xls-dump.py", line 84, in dumpCanonicalXML
    dirEntries = self.strm.getDirectoryEntries()
  File "/usr/share/recoll/filters/msodump.zip/msodumper/xlsstream.py", line 385, in getDirectoryEntries
    obj = self.__getDirectoryObj()
  File "/usr/share/recoll/filters/msodump.zip/msodumper/xlsstream.py", line 371, in __getDirectoryObj
    self.__parseHeader()
  File "/usr/share/recoll/filters/msodump.zip/msodumper/xlsstream.py", line 368, in __parseHeader
    self.pos = self.header.parse()
  File "/usr/share/recoll/filters/msodump.zip/msodumper/ole.py", line 170, in parse
    self.byteOrder = Header.byteOrder(self.bytes[28:30])
  File "/usr/share/recoll/filters/msodump.zip/msodumper/ole.py", line 40, in byteOrder
    b1, b2 = ord(chars[0]), ord(chars[1])
IndexError: string index out of range

Local variables in innermost frame:
chars: ''

Comment 1 Koen 2014-11-23 12:41:57 UTC
Created attachment 960419 [details]
File: backtrace

Comment 2 Koen 2014-11-23 12:41:59 UTC
Created attachment 960420 [details]
File: environ

Comment 3 Koen 2014-11-23 12:45:21 UTC
Probably duplicate of 1167083

Comment 4 Fedora Update System 2015-01-10 16:29:39 UTC
recoll-1.20.1-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/recoll-1.20.1-1.fc21

Comment 5 Fedora Update System 2015-01-10 16:29:50 UTC
recoll-1.20.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/recoll-1.20.1-1.fc20

Comment 6 Fedora Update System 2015-01-11 02:59:19 UTC
Package recoll-1.20.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing recoll-1.20.1-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-0540/recoll-1.20.1-1.fc20
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2015-01-20 21:04:17 UTC
recoll-1.20.1-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2015-01-20 21:07:39 UTC
recoll-1.20.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.