Bug 1169454 (CVE-2014-8106)

Summary: CVE-2014-8106 qemu: cirrus: insufficient blit region checks
Product: [Other] Security Response Reporter: Petr Matousek <pmatouse>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: unspecifiedCC: abaron, aortega, apevec, areis, ayoung, carnil, chrisw, dallan, ehabkost, gkotton, gmollett, jen, jrusnack, knoel, kraxel, lhh, lpeer, markmc, mkenneth, mrezanin, mst, mtosatti, pbonzini, rbalakri, rbryant, rpacheco, sclewis, security-response-team, sisharma, stefanha, yeylon
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
It was found that the Cirrus blit region checks were insufficient. A privileged guest user could use this flaw to write outside of VRAM-allocated buffer boundaries in the host's QEMU process address space with attacker-provided data.
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-06-17 08:27:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1169455, 1169456, 1169457, 1170032, 1170033, 1170571, 1170572, 1170573, 1170612, 1192243, 1192244, 1192247    
Bug Blocks: 1169460    

Description Petr Matousek 2014-12-01 17:32:52 UTC
It was found that the Cirrus blit region checks were insufficient.

A privileged guest user could use this flaw to to write outside of vram
allocated buffer boundaries in the host's qemu process address space with
attacker provided data.

Acknowledgements:

This issue was discovered by Paolo Bonzini of Red Hat.

Comment 7 Petr Matousek 2014-12-04 12:57:57 UTC
Upstream patch submission:

http://lists.gnu.org/archive/html/qemu-devel/2014-12/msg00508.html

Comment 8 Petr Matousek 2014-12-04 13:00:39 UTC
Created qemu tracking bugs for this issue:

Affects: fedora-all [bug 1170612]

Comment 10 Tomas Hoger 2014-12-05 08:52:44 UTC
Note that this really is an incorrect / incomplete CVE-2007-1320 (bug 237342) fix issue.

Comment 11 Petr Matousek 2015-01-22 13:20:58 UTC
Statement:

This issue affects the qemu-kvm packages as shipped with Red Hat Enterprise Linux 6, a future update may address this flaw.

This issue affects the kvm packages as shipped with Red Hat Enterprise Linux 5. Red Hat Enterprise Linux 5 is now in Production 3 Phase of the support and maintenance life cycle. This issue is currently planned to be addressed in future updates. For additional information, refer to the Red Hat Enterprise Linux Life Cycle: https://access.redhat.com/support/policy/updates/errata/.

Comment 14 Fedora Update System 2015-02-17 08:05:01 UTC
qemu-1.6.2-13.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 errata-xmlrpc 2015-03-05 08:14:02 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2015:0349 https://rhn.redhat.com/errata/RHSA-2015-0349.html

Comment 16 errata-xmlrpc 2015-03-05 09:58:56 UTC
This issue has been addressed in the following products:

  RHEV-H and Agents for RHEL-7

Via RHSA-2015:0624 https://rhn.redhat.com/errata/RHSA-2015-0624.html

Comment 17 errata-xmlrpc 2015-03-05 19:30:58 UTC
This issue has been addressed in the following products:

  OpenStack 6 for RHEL 7

Via RHSA-2015:0643 https://rhn.redhat.com/errata/RHSA-2015-0643.html

Comment 18 errata-xmlrpc 2015-04-09 15:44:32 UTC
This issue has been addressed in the following products:

  OpenStack 5 for RHEL 7

Via RHSA-2015:0795 https://rhn.redhat.com/errata/RHSA-2015-0795.html

Comment 19 errata-xmlrpc 2015-04-21 18:00:33 UTC
This issue has been addressed in the following products:

  RHEV-H and Agents for RHEL-6

Via RHSA-2015:0868 https://rhn.redhat.com/errata/RHSA-2015-0868.html

Comment 20 errata-xmlrpc 2015-04-21 18:01:10 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 6

Via RHSA-2015:0867 https://rhn.redhat.com/errata/RHSA-2015-0867.html

Comment 22 errata-xmlrpc 2015-04-28 05:40:38 UTC
This issue has been addressed in the following products:

  OpenStack 5 for RHEL 6
  OpenStack 4 for RHEL 6

Via RHSA-2015:0891 https://rhn.redhat.com/errata/RHSA-2015-0891.html