Bug 1170684 (CVE-2014-8989)

Summary: CVE-2014-8989 kernel: Linux user namespaces can bypass group-based restrictions
Product: [Other] Security Response Reporter: Vincent Danen <vdanen>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: agordeev, aquini, bhu, dhoward, ebiederm, esammons, fhrbata, gansalmon, iboverma, itamar, jforbes, jkacur, jonathan, jross, jwboyer, kernel-maint, kernel-mgr, lgoncalv, lwang, madhu.chinakonda, matt, mchehab, mcressma, mguzik, nmurray, plougher, pmatouse, ppandit, rt-maint, rvrbovsk, slawomir, williams
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-03-17 16:00:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1170688, 1170689    
Bug Blocks: 1164976    

Description Vincent Danen 2014-12-04 15:36:48 UTC
Linux kernel built with the User namespaces(CONFIG_USER_NS) support is vulnerable to a potential 'group' privilege escalation flaw. It could occur when unsharing parts of process' execution context from other processes via unshare(2) or clone(2) calls.

A user/process able to unshare parts of its execution context could use this flaw to gain extra 'group' privileges on a system.

References:
-----------
  -> http://thread.gmane.org/gmane.linux.man/7385/
  -> http://www.openwall.com/lists/oss-security/2014/11/20/4

Comment 2 Vincent Danen 2014-12-04 15:39:26 UTC
Statement:

Not vulnerable. This issue does not affect the versions of the kernel package as shipped with Red Hat Enterprise Linux 5, 6, 7 and Red Hat Enterprise MRG 2.

Comment 4 Petr Matousek 2014-12-04 15:44:15 UTC
Created kernel tracking bugs for this issue:

Affects: fedora-all [bug 1170688]

Comment 8 Fedora Update System 2015-01-11 02:58:20 UTC
kernel-3.17.8-300.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2015-01-13 00:05:54 UTC
kernel-3.17.8-200.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.