Bug 1171722

Summary: Cannot connect to existing dwh database when setting up new remote dwh
Product: Red Hat Enterprise Virtualization Manager Reporter: Petr Matyáš <pmatyas>
Component: ovirt-engine-dwhAssignee: Shirly Radco <sradco>
Status: CLOSED WONTFIX QA Contact: Petr Matyáš <pmatyas>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 3.5.0CC: didi, ecohen, gklein, iheim, lsurette, movciari, pmatyas, rbalakri, Rhev-m-bugs, yeylon
Target Milestone: ---   
Target Release: 3.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-12-09 10:06:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1164308, 1164311, 1166122    
Attachments:
Description Flags
remote ovirt-engine-dwh setup none

Description Petr Matyáš 2014-12-08 13:25:48 UTC
Created attachment 965839 [details]
remote ovirt-engine-dwh setup

Description of problem:
After upgrade to rhevm3.5 from rhevm3.4 setup (engine+dwh+reports), I can't set up new remote dwh to connect to existing dwh database with:
[ ERROR ] Cannot connect to DWH database: Cannot connect to database: could not connect to server: Connection refused        Is the server running on host "10.34.61.71" and accepting   TCP/IP connections on port 5432?
Host is accepting any connections.

Version-Release number of selected component (if applicable):
3.5

How reproducible:
always

Steps to Reproduce:
1. setup rhevm3.4 (engine+dwh+reports)
2. upgrade to rhevm3.5
3. try to setup new remote dwh and connect to existing dwh db

Actual results:
error

Expected results:
successful connection 

Additional info:

Comment 1 Shirly Radco 2014-12-08 14:03:23 UTC
How did you try to connect to the db?
Is it a remote db and you gave its credentials? 
Did you backup and restore in the new host?
Is it on the engine host?

Comment 2 Petr Matyáš 2014-12-08 14:06:43 UTC
It's db on engine, I gave the setup, on dwh machine side, its credentials.

Comment 3 Yedidyah Bar David 2014-12-08 14:22:07 UTC
This happens because postgresql is not configured to accept connections from remote hosts. In 3.4 this was the behavior. In 3.5 it was changed, but only for new setups. So setups upgraded from 3.4 need to do that manually:

Edit the file /var/lib/pgsql/data/postgresql.conf

Find there the line containing 'listen_addresses' and change it to be:

listen_addresses = '*'

If there is no such line there, or only a commented one, add a new such line.

Restart postgresql with:

service postgresql restart

This should be enough.

I think we should add the above to the article explaining how to migrate dwh to another host and not fix the code to do that on upgrade.

Comment 4 Petr Matyáš 2014-12-08 14:37:22 UTC
I can confirm it's working with workaround from comment #3

Comment 5 Shirly Radco 2014-12-09 10:04:45 UTC
I updated the docs with the workaround.