Bug 1172197

Summary: [RHEVM][REST-API] Failed template removal with REST API floods server.log with exceptions
Product: Red Hat Enterprise Virtualization Manager Reporter: Alexandros Gkesos <agkesos>
Component: ovirt-engineAssignee: Juan Hernández <juan.hernandez>
Status: CLOSED ERRATA QA Contact: Karolína Hajná <khajna>
Severity: low Docs Contact:
Priority: low    
Version: 3.4.2CC: agkesos, bazulay, iheim, juan.hernandez, lsurette, pkliczew, ppostler, pstehlik, pvilayat, rbalakri, Rhev-m-bugs, sherold, usurse, yeylon, ykaul
Target Milestone: ovirt-3.6.0-rc   
Target Release: 3.6.0   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-03-09 20:52:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Infra RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 1 Juan Hernández 2014-12-09 15:41:36 UTC
I believe there is no flooding, as the RESTAPI will send the warning to the log only once per failed operation. What happens here, if I understand correctly, is that the caller is sending the same request multiple times, once every 5 seconds, thus the warning in the log is repeated. Unless I'm missing something this should be closed as NOTABUG.

Comment 3 Juan Hernández 2014-12-09 16:28:27 UTC
The warning messages generated for failed requests come directly from RESTEasy, not from our own code. If we want to avoid them then we need to reduce the level of the "org.jboss.resteasy.core.SynchronousDispatcher" category (or some of its parents). This can be done editing the /usr/share/ovirt-engine/service/ovirt-engine/ovirt-engine.xml.in file and adding the following (after the configuration for category "sun.rmi", line 102):

  <logger category="org.jboss.resteasy.core.SynchronousDispatcher">
    <level name="ERROR"/>
  </logger>

Then restart the engine (service ovirt-engine restart).

Note that this file (ovirt-engine.xml.in) isn't a configuration file, so any change there will be lost when the owning package (rhevm-backend) is updated.

We could consider doing this by default, as these log messages in particular aren't really very useful, but in my opinion it is valuable to have the warnings by default, even if they consume some log space, as there may be other useful warnings associated to the same category.

As there is workaround I'm re-targeting to 3.6, for later re-consideration.

Comment 4 Karolína Hajná 2015-04-14 14:06:39 UTC
Verified in oVirt 3.6.0-1

Comment 14 errata-xmlrpc 2016-03-09 20:52:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html