Bug 1172460

Summary: failing to upgrade fedora 19 to f21
Product: [Fedora] Fedora Reporter: Packiyarajah Sureshkumar <sureshp8>
Component: fedupAssignee: Will Woods <wwoods>
Status: CLOSED CANTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 21CC: dugucloud, tflink, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-12-11 14:59:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
snap shot of screen none

Description Packiyarajah Sureshkumar 2014-12-10 05:53:17 UTC
Created attachment 966660 [details]
snap shot of screen

Description of problem:

Downloading failed: The GPG keys listed for the "RPM Fusion for Fedora 21 - Free" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.



Version-Release number of selected component (if applicable): 

 Failing package is: kmodtool-1-23.fc20.noarch



--------

Warning: Group base-x does not have any packages to install.
finding updates 100% [=========================================================]
WARNING: potential problems with upgrade
  mysql-workbench-5.2.47-2.fc19.x86_64 (no replacement) requires ctemplate-2.2-3.fc19.x86_64 (replaced by ctemplate-2.3-3.fc21.x86_64)
  perl-PlRPC-0.2020-13.fc19.noarch (no replacement) requires 4:perl-5.16.3-266.fc19.x86_64 (replaced by 4:perl-5.18.4-305.fc21.x86_64)
verify local files 100% [======================================================]
warning: /var/cache/system-upgrade/rpmfusion-free/packages/kmodtool-1-23.fc20.noarch.rpm: Header V3 RSA/SHA256 Signature, key ID ae688223: NOKEY

Downloading failed: The GPG keys listed for the "RPM Fusion for Fedora 21 - Free" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.


 Failing package is: kmodtool-1-23.fc20.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-21

Comment 1 秋纫 2014-12-10 14:15:06 UTC
What happens if you add --nogpgcheck option to fedup? Hope this may help.

Comment 2 Packiyarajah Sureshkumar 2014-12-11 14:20:45 UTC
Thanks, that works for me :)

Comment 3 Will Woods 2014-12-11 14:59:54 UTC
Sounds like the rpmfusion 'kmodtool' package might be unsigned. You should report this to the rpmfusion maintainers. But I don't control rpmfusion, so I can't fix this.