Bug 1173516

Summary: metainfo file is invalid
Product: [Fedora] Fedora Reporter: Elad Alfassa <elad>
Component: conakry-fontsAssignee: Ankur Sinha (FranciscoD) <sanjay.ankur>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: amir.aharoni, fonts-bugs, pnemade, sanjay.ankur
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: conakry-fonts-20070829-11.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-01-03 19:08:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Elad Alfassa 2014-12-12 10:45:16 UTC
Hi.

Your metainfo file is invalid: on line 10 you need to use &amp; instead of & alone. This error breaks gnome-software under certain conditions, as experienced by a user here:
https://twitter.com/aharoni/status/543333376296378368

Comment 1 Amir Aharoni 2014-12-12 10:51:31 UTC
Thanks for reporting this, Elad :)

I experienced when I saw a message at the bottom suggesting software upgrades.

This would be the first upgrade since I upgraded to Fedora 21.

Comment 2 Ankur Sinha (FranciscoD) 2014-12-12 11:57:40 UTC
Thanks for the bug report. I think this was added as part of the mass addition of metainfo files, since I'm quite certain I didn't add it myself. I'll fix it asap.

Comment 3 Parag Nemade 2014-12-12 12:55:41 UTC
I added that metainfo file and I think I must have missed to run appdata-validate on it. 

Thanks Ankur for fixing this.

Comment 4 Ankur Sinha (FranciscoD) 2014-12-12 17:28:55 UTC
No worries Parag, it was a very straightforward fix :)

Comment 5 Fedora Update System 2014-12-12 17:30:09 UTC
conakry-fonts-20070829-11.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/conakry-fonts-20070829-11.fc21

Comment 6 Fedora Update System 2014-12-13 09:51:10 UTC
Package conakry-fonts-20070829-11.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing conakry-fonts-20070829-11.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-16906/conakry-fonts-20070829-11.fc21
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2015-01-03 19:08:09 UTC
conakry-fonts-20070829-11.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.