Bug 1173992

Summary: NetworkManager-wifi does not connect in rawhide
Product: [Fedora] Fedora Reporter: satellitgo
Component: NetworkManagerAssignee: Dan Williams <dcbw>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: rawhideCC: awilliam, dcbw, psimerda, satellitgo
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-01-29 19:40:41 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1043123    
Attachments:
Description Flags
f22-workstation journalctl -b none

Description satellitgo 2014-12-14 17:15:35 UTC
Description of problem:
NetworkManager-wifi does not connect in rawhide  latest Koji 
 SoaS f22 live 20141213
 Mate f22 live 20141214

Version-Release number of selected component (if applicable):
NetworkManager-wifi-1.0.9.10.0-14.git20140704.fc22.x86_64
will not start wifi connection bios boot from DVD installed to bare metal and live
*Same hardware used for testing f21 

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
NetworkManager-wifi-1.0.9.10.0-14.git20140704.fc22.x86_64
not in Bugzilla!

Expected results:


Additional info:

Comment 1 Fedora Blocker Bugs Application 2014-12-14 20:17:41 UTC
Proposed as a Freeze Exception for 22-alpha by Fedora user satellit using the blocker tracking app because:

 no wireless, networking must work

Comment 2 Adam Williamson 2014-12-15 23:53:41 UTC
You don't provide any information that ties this to NetworkManager at all. We're going to need at least the 'sudo journalctl -b' output from an affected system. It may as well be an issue with the driver, not with NM, from the (lack of) data you've provided so far. Thanks!

Comment 3 satellitgo 2014-12-16 00:36:22 UTC
Created attachment 969360 [details]
f22-workstation journalctl -b

no wireless available f22 workstation x86_64 20141215 on bare metal

Comment 4 satellitgo 2014-12-24 12:17:09 UTC
fixed in KDE 20141222 live KDE as live install(Anaconda 22.13-1 does not allow finding wireless)after install to bare metal wireless is available from bottom bar icon</ref>

Comment 5 satellitgo 2015-01-26 15:48:04 UTC
now requires selenix 0 to access network 
https://fedoraproject.org/wiki/Test_Results:Fedora_22_Rawhide_20150124_Installation

Comment 6 Adam Williamson 2015-01-26 16:51:33 UTC
well that sounds the same as https://bugzilla.redhat.com/show_bug.cgi?id=1185195 , but that should only have showed up since 2015-12-15...

Comment 7 Dan Williams 2015-01-29 19:40:41 UTC
The logs indicate that the wifi interface was found, and appears to be functioning.  Obviously, with boot-from-DVD the user must select the WiFi AP to connect to, since NM does not randomly connect to things...

Anyway, appears to be fixed now, I don't think there was anything wrong with NetworkManager itself (according to the logs...)