Bug 1174207

Summary: /etc/cron.daily/logrotate should not suppress messages and is not marked as a configuration file
Product: Red Hat Enterprise Linux 7 Reporter: Jan Kaluža <jkaluza>
Component: logrotateAssignee: Jan Kaluža <jkaluza>
Status: CLOSED ERRATA QA Contact: Tomas Dolezal <todoleza>
Severity: high Docs Contact: Lenka Špačková <lkuprova>
Priority: medium    
Version: 7.2CC: dnovotny_bugzilla, ejtr, jkaluza, jorton, jscotka, kdudka, mmaslano, ovasik, pchavan, psklenar, qe-baseos-daemons, todoleza, vogel
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: logrotate-3.8.6-5.el7 Doc Type: Bug Fix
Doc Text:
Error messages from `/etc/cron.daily/logrotate` are no longer redirected to `/dev/null` Error messages generated by the daily cronjob of *logrotate* are now sent to the *root* user instead of being silently discarded. In addition, the `/etc/cron.daily/logrotate` script is marked as a configuration file in RPM.
Story Points: ---
Clone Of: 722209 Environment:
Last Closed: 2015-11-19 07:03:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 722209    
Bug Blocks: 782183, 994246, 1075802, 722825    

Comment 6 errata-xmlrpc 2015-11-19 07:03:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2174.html

Comment 7 Kamil Dudka 2016-07-07 15:15:55 UTC
Should this change go also to Fedora in order not to regress in RHEL-8?

Comment 8 Kamil Dudka 2017-01-25 09:51:56 UTC
fixed in logrotate-3.11.0-3.fc26:

http://pkgs.fedoraproject.org/cgit/rpms/logrotate.git/commit/?id=52f81c54