Bug 1177503

Summary: python-txrequests doesn't belong to epel7 because of conflicting build requirements
Product: [Fedora] Fedora EPEL Reporter: Tuomo Soini <tis>
Component: python-txrequestsAssignee: Ralph Bean <rbean>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: epel7CC: rbean
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-02-18 16:52:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tuomo Soini 2014-12-28 10:27:23 UTC
Description of problem:

You can't build python-txrequests for epel7 any more because it has build requirement for python-requets >= 1.2.0 which was on koji when package was build. But that package got removed because there is older version of python-requets in rhel7.

Please fix package to work with python-requests = 1.1.0-8.el7 or remove the broken package from epel7.

Comment 1 Tuomo Soini 2014-12-29 06:41:14 UTC
Sorry, reported against wrong epel version.

Comment 2 Ralph Bean 2015-01-05 18:08:20 UTC
After some local testing, it looks like that the version pinning on requests-1.2.0 is unnecessary.  Everything works fine in a virtualenv with requests-1.1.0.

Comment 3 Fedora Update System 2015-01-05 18:13:52 UTC
python-txrequests-0.9.2-3.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/python-txrequests-0.9.2-3.el7

Comment 4 Fedora Update System 2015-01-24 18:47:40 UTC
python-txrequests-0.9.2-3.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.