Bug 1178247

Summary: irqbalance memory leak
Product: Red Hat Enterprise Linux 6 Reporter: David van de Meer <dieskim>
Component: irqbalanceAssignee: Petr Holasek <pholasek>
Status: CLOSED ERRATA QA Contact: Andrej Manduch <amanduch>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.6CC: dhoward, emcnabb, jeder, mnavrati
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: irqbalance-1.0.7-2.el6 Doc Type: Bug Fix
Doc Text:
Prior to this update, the /sys/bus/pci/devices file handle was not freed properly if the directory was not available. As a consequence, a memory leak occurred. With this update, the file handle is freed as expected when irqbalance cannot open the directory, and memory leaks no longer occur in the described situation.
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-07-22 06:11:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description David van de Meer 2015-01-03 04:00:37 UTC
Irqbalance contains a bug in 1.0.4 which causes a memory leak on systems where /sys/bus/pci/devices is not available, such as on some virtual machines. The problem has been filed and a solution is available from irqbalance by simply updating to the latest version of irqbalance - v1.0.8 

https://github.com/Irqbalance/irqbalance/issues/13 [^]

The issue was resolved upstream but the patch does not apply to 1.0.4:
https://github.com/Irqbalance/irqbalance/commit/699deffdd881bf4759f3fcc4d6ee3e018e4c266e [^]

Comment 5 errata-xmlrpc 2015-07-22 06:11:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1279.html