Bug 1178990

Summary: scvmm EmsRefresh.save_hosts_inventory error ActiveRecord::StatementInvalid
Product: Red Hat CloudForms Management Engine Reporter: Bronagh Sorota <bsorota>
Component: InsightAssignee: Bronagh Sorota <bsorota>
Status: CLOSED ERRATA QA Contact: Milan Falešník <mfalesni>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 5.3.0CC: bmoss, dajohnso, dclarizi, gblomqui, jocarter, jprause, mfalesni, mfeifer
Target Milestone: GAKeywords: ZStream
Target Release: 5.3.3   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 5.3.3 Doc Type: Bug Fix
Doc Text:
The CFME code does not account for SCVMM Hosts without an IP or mgmt IP, which causes inventory not to be collected on SCVMM Hosts. The code has been updated to handle NICs without any IPs or mgmt IP, and inventory is now collected. (Note that SCVMM support is a Technical Preview feature.)
Story Points: ---
Clone Of: 1170813 Environment:
Last Closed: 2015-02-25 16:12:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1170813    
Bug Blocks: 1173616    

Comment 2 CFME Bot 2015-02-09 18:15:39 UTC
New commit detected on cfme/5.3.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=122230e323f54c1b0f500b53a18a20983ccb0bcb

commit 122230e323f54c1b0f500b53a18a20983ccb0bcb
Author:     Bronagh Sorota <bsorota>
AuthorDate: Wed Oct 15 13:58:54 2014 -0400
Commit:     Bronagh Sorota <bsorota>
CommitDate: Mon Feb 9 13:13:45 2015 -0500

    Deals with NICs without any IPs or no mgmt IP
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1178990

 vmdb/app/models/ems_refresh/parsers/scvmm.rb | 15 ++++++++++-----
 1 file changed, 10 insertions(+), 5 deletions(-)

Comment 4 Milan Falešník 2015-02-23 18:30:26 UTC
Verified in 5.3.3.2.20150217120931_a465215 against 5.3.1.10.20141112120709_c36c424.

When I disabled the "Used by management" option on all NICs in one of our scvmm hosts, the 5.3.1.10 could not add the host with the same error message as described in Comment 1. 5.3.3.2 had no problems and it wrote "Found no management IP for <xyz>" in the logs as it is in the commit, the host then appeared in UI.

Comment 6 errata-xmlrpc 2015-02-25 16:12:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0261.html