Bug 1179096

Summary: [RFE] Add explicit way for API consumers to specifiy all pages in an index request
Product: Red Hat Satellite Reporter: Tomas Strachota <tstrachota>
Component: ProvisioningAssignee: Katello Bug Bin <katello-bugs>
Status: CLOSED DUPLICATE QA Contact: Katello QA List <katello-qa-list>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.0.4CC: bbuckingham, bkearney, brwillia, mhjacks
Target Milestone: UnspecifiedKeywords: FutureFeature
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
URL: http://projects.theforeman.org/issues/3652
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-04-30 18:38:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1142258    

Description Tomas Strachota 2015-01-06 08:22:02 UTC
From: https://github.com/theforeman/theforeman.org/pull/119/files#r7659148

Currently a user must specify per_page=<some large number> in order to ensure they receive all members of a collection.  We ought to allow a more explicit method of doing this such as per_page=all.

Comment 1 Tomas Strachota 2015-01-06 08:22:04 UTC
Created from redmine issue http://projects.theforeman.org/issues/3652

Comment 4 Bryan Kearney 2015-04-30 18:38:45 UTC

*** This bug has been marked as a duplicate of bug 1142258 ***