Bug 1179150

Summary: Add Python3 subpackage
Product: [Fedora] Fedora Reporter: Matej Stuchlik <mstuchli>
Component: python-virtualenvAssignee: Matthias Runge <mrunge>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: fschwarz, jberan, lnie, mrunge, mstuchli, smilner
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-virtualenv-1.11.6-2.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-01-15 10:23:04 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
patch to add python3 subpackage none

Description Matej Stuchlik 2015-01-06 10:22:52 UTC
Created attachment 976760 [details]
patch to add python3 subpackage

Could you please add python3 subpackage to virtualenv? You will find a patch that does just that in attachements. I need it to enable python-pip tests, but I believe it would be good to have it in general.

I've explained my reasoning behind why I think that's the case in an email to python-virtualenv-owners:

>> Hi Matej,
>>
>> (Disclaimer: I'm not a virtualenv maintainer for Fedora)
>>
>> Am 12.12.2014 um 10:47 schrieb Matej Stuchlik:
>> > I've attached a patch that adds a python3 subpackage to virtualenv,
>> > would you be OK with applying it to at least master branch? I need it
>> > because python-pip's tests require virtualenv.
>>
>> Are you sure that we need a separate Python 3 subpackage?
>> 1. You can create virtualenvs with Python 3 if you specify the interpreter on
>>    the command line.
>> 2. Python 3.3 has a "venv" module built-in.
>
>Ad 1) I want to run the pip tests under Python3, and since the tests use >virtualenv python API directly, I need it in Python3 sitelib.
>
>Ad 2) it does, but unfortunately the API is different, so it doesn't help in >this case.

Also Donald Stufft, one of the developers of virtualenv, have commented to that effect in [0]: "While I do not believe that venv is (or should) be a complete replacement for virtualenv, (...)"

Thanks in advance!
Matt

[0] https://github.com/pypa/virtualenv/pull/697

Comment 1 Matthias Runge 2015-01-15 10:23:04 UTC
Matej, do you need it for earlier versions than rawhide?

Comment 2 Matej Stuchlik 2015-01-28 14:04:52 UTC
(In reply to Matthias Runge from comment #1)
> Matej, do you need it for earlier versions than rawhide?

If you could do it for F21 as well, I'd be grateful. :)

Comment 3 Fedora Update System 2015-01-28 15:38:39 UTC
python-virtualenv-1.11.6-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/python-virtualenv-1.11.6-2.fc21

Comment 4 lnie 2015-01-29 04:34:54 UTC
python-virtualenv-1.11.6-2.fc21 works

Comment 5 Fedora Update System 2015-02-08 08:59:09 UTC
python-virtualenv-1.11.6-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.