Bug 1180484

Summary: SetHandler to UDS issue
Product: [Fedora] Fedora Reporter: Remi Collet <fedora>
Component: httpdAssignee: Jan Kaluža <jkaluza>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: carl, jkaluza, johnny, jorton, pahan, rcollet
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-03-27 09:17:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Remi Collet 2015-01-09 09:58:15 UTC
Description of problem:
SetHandler to UDS for PHP doesn't work.


Version-Release number of selected component (if applicable):
2.4.10-15


How reproducible:
Always


Steps to Reproduce:
1. change FPM configuration to listen = /run/php-fpm/fpm.sock
2. Change PHP / HTTPD configuration to SetHandler "proxy:unix:/run/php-fpm/fpm.sock|fgci://localhost"
3. (re)start the services

Actual results:
Internal Server Error

[Fri Jan 09 10:52:59.309913 2015] [proxy:warn] [pid 31025] [client 192.168.0.15:34749] AH01144: No protocol handler was valid for the URL /index.php. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.


Expected results:
No error

Additional info:
This works perfectly with httpd 2.4.6-31 in RHEL 7.1

Comment 1 Johnny Robeson 2015-01-17 04:34:12 UTC
does this patch have anything to do with it? https://git.centos.org/blob/rpms!!httpd.git/4126fd92c82d72b12b30be9740eceb714cbb7ca7/SOURCES!httpd-2.4.6-uds.patch

Comment 2 Remi Collet 2015-01-19 07:20:34 UTC
See http://pkgs.fedoraproject.org/cgit/php.git/commit/?id=a8ae4d1be84355298fb6796f8b23385c61c71dd6  (switch to UDS in php-fpm in rawhide)

Comment 3 Jan Kaluža 2015-01-22 08:15:09 UTC
This is caused by one patch not included in 2.4.10 release. 2.4.12 should be released very soon (probably next week) with this patch applied. I will wait with the fix for upcoming httpd release.

Comment 4 Jaroslav Reznik 2015-03-03 16:40:57 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 5 Remi Collet 2015-03-27 09:17:57 UTC
Forget this "not a bug"

Works perfectly (when using fcgi: and not fgci:)