Bug 1180920

Summary: [abrt] WARNING: CPU: 1 PID: 293 at kernel/sched/core.c:7303 __might_sleep+0xbd/0xd0()
Product: [Fedora] Fedora Reporter: Joachim Frieben <jfrieben>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: bugzilla, gansalmon, itamar, jfrieben, jonathan, kernel-maint, madhu.chinakonda, mchehab
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
URL: https://retrace.fedoraproject.org/faf/reports/bthash/58b88cb79a34171d8feca58df930946c6f2e7bb2
Whiteboard: abrt_hash:9e6ea0a024dfb4678c6e0c489a49ac2476647405
Fixed In Version: kernel-4.1.3-201.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-08-05 22:25:47 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
File: dmesg none

Description Joachim Frieben 2015-01-11 21:08:55 UTC
Additional info:
reporter:       libreport-2.3.0
WARNING: CPU: 1 PID: 293 at kernel/sched/core.c:7303 __might_sleep+0xbd/0xd0()
do not call blocking ops when !TASK_RUNNING; state=1 set at [<ffffffff815e26e8>] pccardd+0xf8/0x4c0
Modules linked in: radeon(+) i2c_algo_bit firewire_ohci drm_kms_helper firewire_core e1000e ttm yenta_socket crc_itu_t drm ptp pps_core
CPU: 1 PID: 293 Comm: pccardd Not tainted 3.19.0-0.rc3.git2.1.fc22.x86_64 #1
Hardware name: LENOVO 2768W9J/2768W9J, BIOS 7UET94WW (3.24 ) 10/17/2012
 0000000000000000 0000000065662666 ffff8800b7c4fc28 ffffffff8186cc07
 0000000000000000 ffff8800b7c4fc80 ffff8800b7c4fc68 ffffffff810ac82a
 ffff880035ba0bf0 ffffffff81c83bbd 000000000000026d 0000000000000000
Call Trace:
 [<ffffffff8186cc07>] dump_stack+0x4c/0x65
 [<ffffffff810ac82a>] warn_slowpath_common+0x8a/0xc0
 [<ffffffff810ac8b5>] warn_slowpath_fmt+0x55/0x70
 [<ffffffff81134455>] ? del_timer_sync+0x5/0xf0
 [<ffffffff81028c4a>] ? native_sched_clock+0x2a/0xa0
 [<ffffffff815e26e8>] ? pccardd+0xf8/0x4c0
 [<ffffffff815e26e8>] ? pccardd+0xf8/0x4c0
 [<ffffffff810dd5fd>] __might_sleep+0xbd/0xd0
 [<ffffffff818717dd>] mutex_lock_nested+0x3d/0x440
 [<ffffffff810eab75>] ? local_clock+0x15/0x30
 [<ffffffff81106dcf>] ? lock_release_holdtime.part.29+0xf/0x200
 [<ffffffff81875f66>] ? _raw_spin_unlock_irqrestore+0x36/0x70
 [<ffffffff8110a12d>] ? trace_hardirqs_on_caller+0x15d/0x200
 [<ffffffff815e2750>] pccardd+0x160/0x4c0
 [<ffffffff815e25f0>] ? pcmcia_socket_dev_complete+0x40/0x40
 [<ffffffff810d492f>] kthread+0x11f/0x140
 [<ffffffff810eab75>] ? local_clock+0x15/0x30
 [<ffffffff810d4810>] ? kthread_create_on_node+0x250/0x250
 [<ffffffff81876b7c>] ret_from_fork+0x7c/0xb0
 [<ffffffff810d4810>] ? kthread_create_on_node+0x250/0x250

Comment 1 Joachim Frieben 2015-01-11 21:09:00 UTC
Created attachment 978857 [details]
File: dmesg

Comment 2 Chris Murphy 2015-01-23 03:12:20 UTC
Same for me on i686. There are two processes, pccardd, soaking 100% CPU between them and the fans are running at max. Looks like it could be a debug kernel artifact.

Affected kernels:
3.19.0-0.rc4.git4.1.fc22.i686
3.19.0-0.rc5.git2.1.fc22.i686


Unaffected kernels:
3.18.3-201.fc21.i686
3.19.0-0.rc5.git0.1.fc22.i686




[    4.697454] pps_core: LinuxPPS API ver. 1 registered
[    4.697526] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <giometti@linux.it>
[    4.738765] yenta_cardbus 0000:02:01.0: enabling device (0000 -> 0003)
[    4.746469] PTP clock support registered
[    4.749978] yenta_cardbus 0000:02:01.0: CardBus bridge found [1028:011d]
[    4.750107] yenta_cardbus 0000:02:01.0: O2: enabling read prefetch/write burst. If you experience problems or performance issues, use the yenta_socket parameter 'o2_speedup=off'
[    4.873005] yenta_cardbus 0000:02:01.0: ISA IRQ mask 0x04b8, PCI irq 11
[    4.873116] yenta_cardbus 0000:02:01.0: Socket status: 30000006
[    4.873182] pci_bus 0000:02: Raising subordinate bus# of parent bus (#02) from #02 to #06
[    4.873634] yenta_cardbus 0000:02:01.0: pcmcia: parent PCI bridge window: [io  0xd000-0xefff]
[    4.873733] yenta_cardbus 0000:02:01.0: pcmcia: parent PCI bridge window: [mem 0xf6000000-0xfbffffff]
[    4.873832] pcmcia_socket pcmcia_socket0: cs: memory probe 0xf6000000-0xfbffffff:
[    4.874743]  excluding 0xf7e00000-0xf83fffff 0xfae00000-0xfb3fffff
[    4.874933] yenta_cardbus 0000:02:01.0: pcmcia: parent PCI bridge window: [mem 0x80000000-0x87ffffff pref]
[    4.875058] pcmcia_socket pcmcia_socket0: cs: memory probe 0x80000000-0x87ffffff:
[    4.875205]  excluding 0x80000000-0x87ffffff
[    4.899242] yenta_cardbus 0000:02:01.1: enabling device (0000 -> 0003)
[    4.900887] yenta_cardbus 0000:02:01.1: CardBus bridge found [1028:011d]
[    4.943246] ata_id (221) used greatest stack depth: 5644 bytes left
[    4.990267] [drm] Initialized drm 1.1.0 20060810
[    5.024059] yenta_cardbus 0000:02:01.1: ISA IRQ mask 0x04b8, PCI irq 11
[    5.024136] yenta_cardbus 0000:02:01.1: Socket status: 30000410
[    5.024201] pci_bus 0000:02: Raising subordinate bus# of parent bus (#02) from #06 to #0a
[    5.024315] yenta_cardbus 0000:02:01.1: pcmcia: parent PCI bridge window: [io  0xd000-0xefff]
[    5.024414] yenta_cardbus 0000:02:01.1: pcmcia: parent PCI bridge window: [mem 0xf6000000-0xfbffffff]
[    5.024513] pcmcia_socket pcmcia_socket1: cs: memory probe 0xf6000000-0xfbffffff:
[    5.024653]  excluding 0xf7e00000-0xf83fffff 0xfae00000-0xfb3fffff
[    5.024837] yenta_cardbus 0000:02:01.1: pcmcia: parent PCI bridge window: [mem 0x80000000-0x87ffffff pref]
[    5.024937] pcmcia_socket pcmcia_socket1: cs: memory probe 0x80000000-0x87ffffff:
[    5.029431]  excluding 0x80000000-0x87ffffff
[    5.039594] tg3.c:v3.137 (May 11, 2014)
[    5.138073] ------------[ cut here ]------------
[    5.138152] WARNING: CPU: 0 PID: 222 at kernel/sched/core.c:7300 __might_sleep+0xb8/0xd0()
[    5.138253] do not call blocking ops when !TASK_RUNNING; state=1 set at [<c08f76c0>] pccardd+0xc0/0x450
[    5.138350] Modules linked in: ttm tg3(+) drm ptp ata_generic yenta_socket pps_core pata_acpi
[    5.138646] CPU: 0 PID: 222 Comm: pccardd Not tainted 3.19.0-0.rc5.git2.1.fc22.i686 #1
[    5.138741] Hardware name: Dell Computer Corporation Latitude D600                   /0G5152, BIOS A16 06/29/2005
[    5.138840]  00000000 8ef64fa3 00000000 f6691e08 c0b41e06 f6691e4c f6691e3c c045e8bb
[    5.139130]  c0d1b030 f6691e6c 000000de c0d283b4 00001c84 c04889c8 00001c84 c04889c8
[    5.139395]  00000001 f6668db0 f6668db0 f6691e58 c045e92e 00000009 f6691e4c c0d1b030
[    5.139660] Call Trace:
[    5.139726]  [<c0b41e06>] dump_stack+0x48/0x60
[    5.139791]  [<c045e8bb>] warn_slowpath_common+0x8b/0xc0
[    5.139854]  [<c04889c8>] ? __might_sleep+0xb8/0xd0
[    5.139916]  [<c04889c8>] ? __might_sleep+0xb8/0xd0
[    5.139978]  [<c045e92e>] warn_slowpath_fmt+0x3e/0x60
[    5.140059]  [<c04889c8>] __might_sleep+0xb8/0xd0
[    5.140121]  [<c08f76c0>] ? pccardd+0xc0/0x450
[    5.140182]  [<c08f76c0>] ? pccardd+0xc0/0x450
[    5.140245]  [<c0b4665e>] mutex_lock_nested+0x2e/0x3e0
[    5.140309]  [<c04b078c>] ? trace_hardirqs_on_caller+0x13c/0x1e0
[    5.140373]  [<c04b083b>] ? trace_hardirqs_on+0xb/0x10
[    5.140436]  [<c08f771e>] pccardd+0x11e/0x450
[    5.140498]  [<c08f7600>] ? pcmcia_socket_dev_complete+0x40/0x40
[    5.140562]  [<c0480b7d>] kthread+0xcd/0xe0
[    5.140624]  [<c04b083b>] ? trace_hardirqs_on+0xb/0x10
[    5.140688]  [<c0b4a881>] ret_from_kernel_thread+0x21/0x30
[    5.140751]  [<c0480ab0>] ? kthread_create_on_node+0x180/0x180
[    5.140814] ---[ end trace c56d30facffa26e6 ]---
[    5.143312] random: nonblocking pool is initialized
[    5.175849] tg3 0000:02:00.0 eth0: Tigon3 [partno(BCM95705A50) rev 3001] (PCI:33MHz:32-bit) MAC address 00:0f:1f:9f:34:f5
[    5.175962] tg3 0000:02:00.0 eth0: attached PHY is 5705 (10/100/1000Base-T Ethernet) (WireSpeed[1], EEE[0])
[    5.176092] tg3 0000:02:00.0 eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
[    5.176189] tg3 0000:02:00.0 eth0: dma_rwctrl[763f0000] dma_mask[64-bit]
[    5.522132] tg3 0000:02:00.0 enp2s0: renamed from eth0
[    5.621894] pcmcia_socket pcmcia_socket0: cs: memory probe 0x0c0000-0x0fffff:
[    5.622070]  excluding 0xc0000-0xcffff 0xf0000-0xfffff
[    5.632743] pcmcia_socket pcmcia_socket0: cs: memory probe 0xa0000000-0xa0ffffff:
[    5.632952]  clean.
[    5.638615] pcmcia_socket pcmcia_socket0: cs: memory probe 0x60000000-0x60ffffff:
[    5.638807]  excluding 0x60000000-0x60ffffff
[    5.909080] pcmcia_socket pcmcia_socket1: pccard: PCMCIA card inserted into slot 1
[    5.909527] pcmcia_socket pcmcia_socket1: cs: memory probe 0xf6000000-0xf7dfffff:
[    5.945881]  excluding 0xf6f00000-0xf70dffff
[    5.968984] pcmcia_socket pcmcia_socket1: cs: memory probe 0xf8400000-0xfadfffff:

Comment 3 Josh Boyer 2015-02-16 14:02:11 UTC
*** Bug 1192758 has been marked as a duplicate of this bug. ***

Comment 4 Jaroslav Reznik 2015-03-03 16:41:40 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 5 Fedora Update System 2015-07-30 17:52:09 UTC
kernel-4.1.3-201.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/kernel-4.1.3-201.fc22

Comment 6 Fedora Update System 2015-07-31 07:56:11 UTC
Package kernel-4.1.3-201.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-4.1.3-201.fc22'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-12437/kernel-4.1.3-201.fc22
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2015-08-05 22:25:47 UTC
kernel-4.1.3-201.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.