Bug 118303

Summary: unable to delete users in adminstration section
Product: [Retired] Red Hat Enterprise CMS Reporter: martin black <martin.black>
Component: APLAWSAssignee: ccm-bugs-list
Status: CLOSED WONTFIX QA Contact: Daniel Berrange <berrange>
Severity: medium Docs Contact:
Priority: medium    
Version: nightly   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-03-15 13:48:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description martin black 2004-03-15 13:39:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
In Administration I am unable to delete a user.  When I 
click 'delete' I get 'User Delete Failed'

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.search for user 'david'
2. click name link
3. click delete user
    

Actual Results:  I get 'User Delete Failed'

Expected Results:  I should be able to delete user

Additional info:

In this case the user has left the council so there is a security 
risk, thus I want to get him off the system.  He has published items 
in the past.  I can get around this by changing his password but I'd 
rather delete him complelety.

Comment 1 Daniel Berrange 2004-03-15 13:48:31 UTC
As a general rule it is impossible to delete a user if they have ever
created any objects (eg, content) within the system, since the user
information is required for auditing purposes. The solution is to
login as admin & change their password so they can no longer access
the system.