Bug 1183454

Summary: %post(mock-1.2.3-1.fc21.noarch) scriptlet failed
Product: [Fedora] Fedora Reporter: Ralf Corsepius <rc040203>
Component: mockAssignee: Miroslav Suchý <msuchy>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 23CC: jdisnard, mebrown, msimacek, msuchy, praiskup, williams
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: mock-1.2.6-1.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-08-08 21:20:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ralf Corsepius 2015-01-19 05:54:09 UTC
Description of problem:

The mock-rpm carries broken %postin scriptlets:

...
  Installing : mock-1.2.3-1.fc21.noarch                                   38/38 
warning: %post(mock-1.2.3-1.fc21.noarch) scriptlet failed, exit status 254
Non-fatal POSTIN scriptlet failure in rpm package mock-1.2.3-1.fc21.noarch
...


Version-Release number of selected component (if applicable):
mock-1.2.3-1.fc21
mock-1.2.3-1.fc20

How reproducible:
Always.

Steps to Reproduce:
1. mock -r fedora-21-x86_64 --init
2. mock -r fedora-21-x86_64 --install mock

Actual results:
C.f. above 

Expected results:
Funktion.

Additional info:

Comment 1 Miroslav Suchý 2015-01-19 07:56:28 UTC
This only happen if you install mock inside of mock. Should not affect regular installations.

Fixed in:
* 7b4db54 (HEAD, master) touch /etc/os-release after install @buildsys-build [RHBZ#1183454]
* a7a4799 parse /etc/os-release only if it exists and size is non-zero [RHBZ#1183454]

Comment 2 Ralf Corsepius 2015-01-19 12:43:22 UTC
(In reply to Miroslav Suchý from comment #1)
> This only happen if you install mock inside of mock. Should not affect
> regular installations.

Well, such incidents normally indicate a missing dependency.

Comment 3 Fedora Update System 2015-01-28 15:19:46 UTC
mock-1.2.5-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/mock-1.2.5-1.el7

Comment 4 Fedora Update System 2015-01-28 15:21:12 UTC
mock-1.2.5-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.2.5-1.el6

Comment 5 Fedora Update System 2015-01-28 15:22:20 UTC
mock-1.2.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.2.5-1.fc20

Comment 6 Fedora Update System 2015-01-28 15:23:35 UTC
mock-1.2.5-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/mock-1.2.5-1.fc21

Comment 7 Fedora Update System 2015-01-28 21:41:36 UTC
Package mock-1.2.5-1.el7:
* should fix your issue,
* was pushed to the Fedora EPEL 7 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing mock-1.2.5-1.el7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-0508/mock-1.2.5-1.el7
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2015-02-02 17:22:13 UTC
mock-1.2.5-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2015-02-03 04:42:23 UTC
mock-1.2.6-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.2.6-1.el6

Comment 10 Fedora Update System 2015-02-03 04:43:01 UTC
mock-1.2.6-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/mock-1.2.6-1.el7

Comment 11 Fedora Update System 2015-02-03 04:43:21 UTC
mock-1.2.6-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.2.6-1.fc20

Comment 12 Fedora Update System 2015-02-03 04:43:59 UTC
mock-1.2.6-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/mock-1.2.6-1.fc21

Comment 13 Fedora Update System 2015-02-09 05:29:13 UTC
mock-1.2.6-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2015-02-15 02:55:26 UTC
mock-1.2.6-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2015-02-20 00:32:52 UTC
mock-1.2.6-1.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2015-02-20 00:33:43 UTC
mock-1.2.6-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Ralf Corsepius 2015-07-19 07:19:15 UTC
Reopening. This bug is back in Fedora 23:

warning: %post(mock-1.2.10-2.fc23.noarch) scriptlet failed, exit status 254
Non-fatal POSTIN scriptlet failure in rpm package mock-1.2.10-2.fc23.noarch

Comment 18 Miroslav Suchý 2016-08-08 21:20:15 UTC
This was fixed for sure as part of bug 1305367.

*** This bug has been marked as a duplicate of bug 1305367 ***