Bug 118427

Summary: Hard coded dependancy on XFree86
Product: [Fedora] Fedora Reporter: Mike A. Harris <mharris>
Component: libgnomeprintAssignee: Owen Taylor <otaylor>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1.116.0-10 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-03-17 04:46:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 118423    

Description Mike A. Harris 2004-03-16 17:37:48 UTC
The libgnomeprint spec file contains the following hard coded
dependancy which makes it unnecessarily dependant on XFree86:

    PreReq: XFree86

I've had a quick look to see if I could determine why the dep
was added, but couldn't see anything obvious.  I believe this
dependancy can just be removed, however someone should check
to ensure that is ok first.  If there is a dependancy still
present in the package which requires a hard dep on something
from the X11 packaging, please let me know what the real dependancy
is on, and I will try to accomodate it with a solution, perhaps
a virtual provides or something else.

Thanks in advance.

Comment 1 Mike A. Harris 2004-03-17 04:46:52 UTC
Fixed in libgnomeprint-1.116.0-10 in dist-fc2