Bug 1184933

Summary: login screen stuck after switching users
Product: [Fedora] Fedora Reporter: Kamil Páral <kparal>
Component: gdmAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: awilliam, danofsatx, fmuellner, jeff.raber, jones.peter.busi, moez.roy, nekohayo, normand, otaylor, robatino, rstrode
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedBlocker
Fixed In Version: gdm-3.15.3.1-3.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-03-26 05:27:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1043125    

Description Kamil Páral 2015-01-22 14:07:34 UTC
Description of problem:
If you try to switch user accounts (meaning live switching, not logging out), you'll very soon end up with just a blank gray screen and a cursor, nothing else.

This has been reported upstream here:
https://bugzilla.gnome.org/show_bug.cgi?id=719418

It is very easy to trigger this bug (or let's say it's very hard to not see this bug). You just need to create two users and play with account switching for a minute or two (switching, not logging out). Some reproducers are included in the upstream bug report. I've tried to find out the simplest reproducer and attach it below in the reproducer section.

I have attached a video here, please watch it:
https://bugzilla.gnome.org/attachment.cgi?id=295173
The two users have a different wallpaper (a red and a green one) so that you can easily distinguish them.

After you end up in the gray screen, there's nothing you can do as a general user, there is no button and no keyboard shortcuts work (like ctrl+alt+del). I've tried to wait, and after waiting 7 minutes the screen was still all gray. The general user will need to hard-reset the machine.
Power users can switch to the existing user sessions using Ctrl+Alt+Fx shortcuts.

Version-Release number of selected component (if applicable):
gnome-shell-3.15.3-1.fc22.x86_64
gdm-3.15.3.1-2.fc22.x86_64
systemd-218-3.fc22.x86_64

How reproducible:
100%
confirmed on several different bare metal machines and also in a cleanly installed VM
confirmed by different users (all of my family members)

Steps to Reproduce:
1. create two users (let's call them Red and Green), reboot
2. log in as Red, click Switch User
3. log in as Green, click Switch User
4. log in as Red, click Switch User
5. see blank gray screen

Actual results:
user switching is broken

Expected results:
users can switch their profiles without problems

Comment 1 Kamil Páral 2015-01-22 14:21:08 UTC
I'm proposing this as a F22 Beta blocker due to this criterion:
"Shutting down, logging out and rebooting must work using standard console commands and the mechanisms offered (if any) by all release-blocking desktops. "
https://fedoraproject.org/wiki/Fedora_22_Beta_Release_Criteria#Shutdown.2C_reboot.2C_logout

Account switching is not mentioned in that criterion, but it seems to me that it's in the same spirit as "logging out" (and logging in, which is in a different criterion), it's just not explicitly mentioned.

Alternatively, this can be considered to be a conditional violation of all of our graphical-related criteria, provided that multiple users use your machine and use account switching. The user in question is either precluded from returning to his or her existing session, or even logging in completely (see the first use case in the upstream report). Once that happens, only hard reboot "resolves" this for a general user.

Comment 2 Kamil Páral 2015-01-23 09:11:35 UTC
I tested it and it really fixes the problem, great!

Ray, would it be difficult to push the same fix into F21 as well? It's a very visible issue.

Comment 3 Fedora Update System 2015-01-23 16:40:15 UTC
gdm-3.14.1-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/gdm-3.14.1-3.fc21

Comment 4 Kamil Páral 2015-01-26 17:26:05 UTC
This is still not fixed, please refer to the upstream report.

Comment 5 Dan Mossor [danofsatx] 2015-01-26 17:47:22 UTC
Discussed at Fedora Blocker Review Meeting 2015-01-26

http://meetbot.fedoraproject.org/fedora-blocker-review/2015-01-26/f22-blocker-review.2015-01-26-17.00.log.txt

AcceptedBlocker for Beta - This bug is a conditional violation of the criterion: "Shutting down, logging out and rebooting must work using standard console commands and the mechanisms offered (if any) by all release-blocking desktops." As "Switch User" is an offered mechanism.

Comment 6 Kamil Páral 2015-03-11 15:22:17 UTC
The core problem seems to have been fixed in gdm 3.15.90, per the upstream report. There is still some mouse cursor related issue present, but that will be filed separately (and I'll propose it as another blocker, if needed).

Comment 7 Ray Strode [halfline] 2015-03-11 16:48:56 UTC
maybe we should keep this open for f21 still?

Comment 8 Kamil Páral 2015-03-12 10:18:39 UTC
Ugh, I still experience issues on bare metal, I'm adding back the blocker bug keywords :/ Let me know if it makes sense to split this into two bugs, one for F21 and one for F22.

Comment 9 Kamil Páral 2015-03-18 08:45:03 UTC
This has been fixed upstream. Now we just need a new build for F22.

Comment 10 Adam Williamson 2015-03-26 05:27:45 UTC
Near as I can tell, this can be closed: the fix - https://git.gnome.org/browse/gnome-shell/commit/?id=b1de1ada25ef155f20864447c78b0e18c71a5586 - went into GNOME Shell 3.15.92, which is in stable for F22 already.

I am closing this again provisionally, feel free to re-open if I interpreted wrongly.

Comment 11 Fedora Update System 2015-04-11 15:13:45 UTC
gdm-3.14.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/gdm-3.14.2-1.fc21