Bug 1191855

Summary: firebug raises "TypeError: t is undefined" on selecting subnet from "Hostgroup --> New Hostgroup --> Network"
Product: Red Hat Satellite Reporter: Sachin Ghai <sghai>
Component: WebUIAssignee: Ohad Levy <ohadlevy>
WebUI sub component: Foreman QA Contact: jcallaha
Status: CLOSED ERRATA Docs Contact:
Severity: medium    
Priority: medium CC: bkearney, jcallaha, mhulan
Version: 6.1.0Keywords: Triaged
Target Milestone: Unspecified   
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-27 08:47:51 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Firebug raises "TypeError: t is undefined" on selecting subnet from dropdown.
none
Chrome console error none

Description Sachin Ghai 2015-02-12 07:07:20 UTC
Created attachment 990751 [details]
Firebug raises "TypeError: t is undefined" on selecting subnet from dropdown.

Description of problem:
firebug raises "TypeError: t is undefined" on selecting subnet from "Hostgroup --> New Hostgroup --> Network

TypeError: t is undefined
	

...bnet_id"),t=e.val(),n=e.data("subnets");return t==""?!0:n[t].ipam}$(document).on...

	

Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150210.0
Sat6.1.0 beta snap2

How reproducible:
always

Steps to Reproduce:
1. Go to "configure" --> Host Group --> New Host Group --> Network
2. select subnet from dropdown


Actual results:
Firebug raises "TypeError: t is undefined" on selecting subnet from dropdown.
	

Expected results:
no error should be raised on selecting subnet dropdown

Additional info:

Comment 2 Bryan Kearney 2015-02-18 21:10:04 UTC
Created redmine issue http://projects.theforeman.org/issues/9443 from this bug

Comment 3 Bryan Kearney 2015-02-19 14:03:57 UTC
Dominic says in the upstream bug that this is actually fixed by http://projects.theforeman.org/issues/7456 which will be delivered in 1.8. Since this is a medium priority, I am moving this to ON_QA for 6.2 to be verified there.

Comment 4 Steve Loranz 2015-03-11 22:13:53 UTC
Upstream bug assigned to ohadlevy@redhat.com

Comment 7 jcallaha 2015-05-21 18:44:36 UTC
Failed QA

attaching screenshot of error

Uncaught TypeError: Cannot read property 'undefined' of undefined
selectedSubnetHasIPAM @ host_edit-f28aad5e3f4a480dcd142fd790e49243.js:1subnet_
selected @ host_edit-f28aad5e3f4a480dcd142fd790e49243.js:1onchange @ new:1

Comment 8 jcallaha 2015-05-21 18:45:40 UTC
Created attachment 1028363 [details]
Chrome console error

Comment 9 Marek Hulan 2015-05-22 06:00:40 UTC
Please test when 6.2 is available as suggested in previous comments. Moving back to ON_QA.

Comment 10 jcallaha 2015-10-28 18:05:32 UTC
Verified in upstream. No errors found during selection.

 HOSTNAME: rhsm-qe-1.rhq.lab.eng.bos.redhat.com
       OS: redhat
  RELEASE: Red Hat Enterprise Linux Server release 7.1 (Maipo)
  FOREMAN: 1.11.0-develop
     RUBY: ruby 2.0.0p598 (2014-11-13) [x86_64-linux]
   PUPPET: 3.8.3

Comment 13 errata-xmlrpc 2016-07-27 08:47:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500