Bug 1192758

Summary: [abrt] WARNING: CPU: 1 PID: 293 at kernel/sched/core.c:7354 __might_sleep+0x87/0x90()
Product: [Fedora] Fedora Reporter: Joachim Frieben <jfrieben>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: gansalmon, itamar, jfrieben, jonathan, kernel-maint, madhu.chinakonda, mchehab, psimerda
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
URL: https://retrace.fedoraproject.org/faf/reports/bthash/7b075672a1d6eb7d6213e8d06c1ea5e040fbf227
Whiteboard: abrt_hash:9e6ea0a024dfb4678c6e0c489a49ac2476647405
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-02-16 14:02:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
File: dmesg none

Description Joachim Frieben 2015-02-15 05:53:10 UTC
Additional info:
reporter:       libreport-2.3.0
WARNING: CPU: 1 PID: 293 at kernel/sched/core.c:7354 __might_sleep+0x87/0x90()
do not call blocking ops when !TASK_RUNNING; state=1 set at [<ffffffff815fdb58>] pccardd+0xd8/0x4b0
Modules linked in: radeon(+) i2c_algo_bit drm_kms_helper sdhci_pci sdhci e1000e ttm firewire_ohci mmc_core firewire_core yenta_socket drm crc_itu_t ptp pps_core
CPU: 1 PID: 293 Comm: pccardd Not tainted 3.20.0-0.rc0.git5.1.fc22.x86_64 #1
Hardware name: LENOVO 2768W9J/2768W9J, BIOS 7UET94WW (3.24 ) 10/17/2012
 0000000000000000 000000002aa712a3 ffff88013493fc28 ffffffff818760f7
 0000000000000000 ffff88013493fc80 ffff88013493fc68 ffffffff810ab80a
 ffffffff824851c0 ffffffff81c830b4 0000000000000271 0000000000000000
Call Trace:
 [<ffffffff818760f7>] dump_stack+0x4c/0x65
 [<ffffffff810ab80a>] warn_slowpath_common+0x8a/0xc0
 [<ffffffff810ab895>] warn_slowpath_fmt+0x55/0x70
 [<ffffffff81133e45>] ? del_timer_sync+0x5/0xf0
 [<ffffffff81027b9d>] ? native_sched_clock+0x2d/0xa0
 [<ffffffff815fdb58>] ? pccardd+0xd8/0x4b0
 [<ffffffff815fdb58>] ? pccardd+0xd8/0x4b0
 [<ffffffff810db997>] __might_sleep+0x87/0x90
 [<ffffffff8187b0bd>] mutex_lock_nested+0x3d/0x450
 [<ffffffff810e83f5>] ? local_clock+0x15/0x30
 [<ffffffff81103c0f>] ? lock_release_holdtime.part.29+0xf/0x200
 [<ffffffff8110755d>] ? trace_hardirqs_on_caller+0x13d/0x1e0
 [<ffffffff815fdbbc>] pccardd+0x13c/0x4b0
 [<ffffffff815fda80>] ? pcmcia_socket_uevent+0x30/0x30
 [<ffffffff810d35e4>] kthread+0x104/0x120
 [<ffffffff810e83f5>] ? local_clock+0x15/0x30
 [<ffffffff810d34e0>] ? kthread_create_on_node+0x250/0x250
 [<ffffffff8187f83c>] ret_from_fork+0x7c/0xb0
 [<ffffffff810d34e0>] ? kthread_create_on_node+0x250/0x250

Potential duplicate: bug 1180920

Comment 1 Joachim Frieben 2015-02-15 05:53:15 UTC
Created attachment 991822 [details]
File: dmesg

Comment 2 Josh Boyer 2015-02-16 14:02:11 UTC

*** This bug has been marked as a duplicate of bug 1180920 ***