Bug 1192921

Summary: [abrt] gnuplot-wx: wxVLogFatalError(): gnuplot-wx killed by SIGABRT
Product: [Fedora] Fedora Reporter: Joachim Frieben <jfrieben>
Component: wxGTKAssignee: Dan Horák <dan>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: dan, fkluknav, jfrieben, orion, pertusus
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
URL: https://retrace.fedoraproject.org/faf/reports/bthash/bece239db8bfb5875ef4f7421b179ad48076430e
Whiteboard: abrt_hash:f8b54f9c86842e3563df3442e9201b8d697b5740
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-03-13 16:08:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
File: backtrace
none
File: cgroup
none
File: core_backtrace
none
File: dso_list
none
File: environ
none
File: limits
none
File: maps
none
File: open_fds
none
File: proc_pid_status
none
File: var_log_messages none

Description Joachim Frieben 2015-02-16 08:45:33 UTC
Description of problem:
Run gnuplot after installing package gnuplot-wx and removing gnuplot instead.

Version-Release number of selected component:
gnuplot-wx-5.0.0-6.fc22

Additional info:
reporter:       libreport-2.3.0
backtrace_rating: 4
cmdline:        gnuplot
crash_function: wxVLogFatalError
executable:     /usr/bin/gnuplot-wx
kernel:         3.19.0-1.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1001

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 wxVLogFatalError at src/common/log.cpp:144
 #3 wxLogFatalError at src/common/log.cpp:152
 #4 wxAppConsole::CheckBuildOptions at src/common/appbase.cpp:427
 #5 wxCreateApp at ../../src/wxterminal/wxt_gui.cpp:256
 #6 wxEntryStart at src/common/init.cpp:273
 #7 wxInitialize at src/common/init.cpp:479
 #8 wxt_init at ../../src/wxterminal/wxt_gui.cpp:1768
 #9 term_initialise at ../../src/term.c:488
 #10 do_plot at ../../src/graphics.c:523
 #11 eval_plots at ../../src/plot2d.c:3361

Comment 1 Joachim Frieben 2015-02-16 08:45:37 UTC
Created attachment 992075 [details]
File: backtrace

Comment 2 Joachim Frieben 2015-02-16 08:45:38 UTC
Created attachment 992076 [details]
File: cgroup

Comment 3 Joachim Frieben 2015-02-16 08:45:40 UTC
Created attachment 992077 [details]
File: core_backtrace

Comment 4 Joachim Frieben 2015-02-16 08:45:41 UTC
Created attachment 992078 [details]
File: dso_list

Comment 5 Joachim Frieben 2015-02-16 08:45:42 UTC
Created attachment 992079 [details]
File: environ

Comment 6 Joachim Frieben 2015-02-16 08:45:43 UTC
Created attachment 992080 [details]
File: limits

Comment 7 Joachim Frieben 2015-02-16 08:45:45 UTC
Created attachment 992081 [details]
File: maps

Comment 8 Joachim Frieben 2015-02-16 08:45:47 UTC
Created attachment 992082 [details]
File: open_fds

Comment 9 Joachim Frieben 2015-02-16 08:45:48 UTC
Created attachment 992083 [details]
File: proc_pid_status

Comment 10 Joachim Frieben 2015-02-16 08:45:49 UTC
Created attachment 992084 [details]
File: var_log_messages

Comment 11 Frantisek Kluknavsky 2015-02-19 14:28:57 UTC
Thanks for your report. It is the same issue as https://bugzilla.redhat.com/show_bug.cgi?id=1190971 . Caused by gcc-5. WxGTK needs to be rebuilt in Fedora 22.

Comment 12 Frantisek Kluknavsky 2015-02-19 14:34:41 UTC
As a workaround, wxGTK3.fc23 is already rebuilt.

Comment 13 Frantisek Kluknavsky 2015-02-19 15:25:01 UTC
https://lists.fedoraproject.org/pipermail/devel/2015-February/208044.html
"That is a WxGTK bug.  __GXX_ABI_VERSION can change, but usually the result
is still ABI compatible, g++ emits just some aliases when mangling has
changed."

Comment 14 Orion Poplawski 2015-02-22 21:37:36 UTC
So, can we get this check removed from wxGTK?

Did this signature change once again?  I'm seeing:

106: Fatal Error: Mismatch between the program and library build versions detected.
106: The library used 2.8 (no debug,Unicode,compiler with C++ ABI 999999,wx containers,compatible with 2.4,compatible with 2.6),
106: and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1008,wx containers,compatible with 2.4,compatible with 2.6).

with wxGTK-devel-2.8.12-14.fc23.x86_64 which was built on the 12th.

Comment 15 Dan Horák 2015-03-13 16:08:27 UTC

*** This bug has been marked as a duplicate of bug 1200611 ***

Comment 16 Joachim Frieben 2015-03-13 17:46:35 UTC
Update wxGTK-2.8.12-16.fc22 fixes bug 1192921 but now a warning is issued by gnuplot, namely:

"Warning: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1008,wx containers,compatible with 2.4,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 999999,wx containers,compatible with 2.4,compatible with 2.6).

Maybe a matter of simply rebuilding the gnuplot package.