Bug 119376

Summary: (NET 3C905)not acquiring IP settings from DI-614+ ( my D-Link Router )
Product: [Fedora] Fedora Reporter: Jaakan Shorter <jaakanshorter>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 19:02:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jaakan Shorter 2004-03-29 22:34:12 UTC
Description of problem:

PC with Fedora Core 2 test2 is not acquiring
IP settings from DI-614+ ( my D-Link Router ) 
while my CP with Windows XP sp1 is 

Version-Release number of selected component (if applicable):
PC#1
P3-667, 512MB ram, Win Xp sp1, 10/100 on board and USB 10/100

PC#2
P2-400, 256Mb ram, 2Gb HD, DVDrom drive, Nic 3com 509c 10/100
it's running with Fedora Core 2 test2

DI-614+ ( a D-Link Router )

Cable modem/hispeed net connection

How reproducible:
needed

Cable Modem  
DI-614+ ( a D-Link Router )
Need 2 PCs 
One Windows XP w/ 3com NIC
One for Linux w/ 3com NIC

Steps to Reproduce:
1.setup DI-614+, Connect WAN port to Cable Modem  
2.boot up Windows PC
3.clean install "Fedora Core 2 test2" on second PC and set for DHCP
  
Actual results: 

Windows PC will get IP
Fedora Core 2 test2 PC doesn't get IP

Expected results:
Windows PC should get IP
Fedora C2 T2 PC should get IP

Additional info:
DI-614+ 
Current Firmware Version: 3.35  
Firmware Date: Thu, 05 Feb 2004

Comment 1 Jaakan Shorter 2004-03-29 23:50:29 UTC
I meant 3c905 NIC not 509.

Comment 2 Jaakan Shorter 2004-03-31 22:50:08 UTC
After more testing

Dynamic IP does show windows networking under "network"
but zero PCs listed.

Static IP doesn't work and doesn't show windows network 
under "network"

It can only ping it self.

This is from D-link

Date of Reply: 3/30/2004 10:15:00 PM

Products:   DI-614+_revB
Operating System:  Linux

Sorry, we don't support Linux.
Try just setting the IP addresses statically in the 192.168.0.x range 
in the 255.255.255.0 subnet mask and the Gateway to 192.168.0.1
Dns servers to 4.2.2.3 & 192.9.9.3

Comment 3 Jaakan Shorter 2004-04-02 09:08:28 UTC
it's the 3c905 driver, I tried a USB to 10/100 adpt and it works.

Comment 4 Seth Vidal 2004-04-05 16:51:05 UTC
probably related to:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=119965

Comment 5 Bill Nottingham 2004-05-05 03:14:05 UTC

*** This bug has been marked as a duplicate of 119965 ***

Comment 6 Red Hat Bugzilla 2006-02-21 19:02:13 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.