Bug 1195139

Summary: policycoreutils-python3 shouldn't require audit-libs-python
Product: [Fedora] Fedora Reporter: Bohuslav "Slavek" Kabrda <bkabrda>
Component: policycoreutilsAssignee: Daniel Walsh <dwalsh>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 22CC: dwalsh, mgrepl, plautrba
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: policycoreutils-2.3-16.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-03-13 17:13:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bohuslav "Slavek" Kabrda 2015-02-23 08:29:05 UTC
audit-libs-python package only provides Python 2 bindings that are not importable in Python 3. AFAICS policycoreutils-python3 works fine even without using any audit code, so it should be ok to just drop audit-libs-python dependency. Please do this in F22 and rawhide, so that we can successfully implement https://fedoraproject.org/wiki/Changes/Python_3_Migration_Improvements

Comment 1 Petr Lautrbach 2015-02-23 12:19:07 UTC
This is just a cosmetic change which won't probably solve your problem.

The thing is that policycoreutils-python can't be replaced be policycoreutils-python3 now. Sadly, policycoreutils-python3 port seems to be incomplete and unusable in this moment. There are two missing parts:

- sepolgen module is not ported to python3 

I've started to port the code in my personal github branch [1] but it's not ready yet as 'make test PYTHON=python3' still fails

- audit2allow and other tools imports seobject which uses audit.audit_log_semanage_message to log ROLE related messages


[1] https://github.com/bachradsusi/selinux/tree/sepolgen-python3

Comment 2 Fedora Update System 2015-02-24 19:41:00 UTC
policycoreutils-2.3-16.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/policycoreutils-2.3-16.fc22

Comment 3 Fedora Update System 2015-02-25 15:15:59 UTC
Package policycoreutils-2.3-16.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing policycoreutils-2.3-16.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2577/policycoreutils-2.3-16.fc22
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2015-03-13 17:13:57 UTC
policycoreutils-2.3-16.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.