Bug 1196953

Summary: Proxy cmdline directive not used
Product: [Fedora] Fedora Reporter: A.J. Werkman <aj.werkman>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 22CC: aj.werkman, anaconda-maint-list, dshea, g.kaviyarasu, jonathan, sjenning, vanmeeuwen+fedora
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: anaconda-22.20.7-1.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-05-11 17:54:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
updates.img
none
proxyfix.patch
none
Anaconda.log
none
Syslog
none
Packaing.log none

Description A.J. Werkman 2015-02-27 06:23:51 UTC
Description of problem:
When setting the inst..proxy directive from the kernel boot commandline, anaconda does not use it.

Version-Release number of selected component (if applicable):
22AlphaTC5

How reproducible:
Everytime

Steps to Reproduce:
1. Type inst.repo on the cmdline.
2. Start installing behind a firewall.
3. Anaconda can not fond a mirror or installation tree.

Actual results:
Proxy set in UI, but not used

Expected results:
Anaconda should go throughout the proxy and find it's installation tree.

Additional info:
When inspecting the proxy settings in the ui, they show up.

Comment 1 Seth Jennings 2015-03-21 02:28:13 UTC
I am experience thing same issue with F22 Alpha.

stage2 files (squash.img and friends) and repo metadata are downloaded via the proxy but packages are not.

cmdline:
append initrd=initrd.img ks=ftp://ftpserver/f22_alpha_server.ks proxy=http://proxy:3128 stage2=http://mirror.pnl.gov/fedora/linux/releases/test/22_Alpha/Server/x86_64/os

kickstart:
url --url=http://mirror.pnl.gov/fedora/linux/releases/test/22_Alpha/Server/x86_64/os --proxy=proxy:3128

When I go into the GUI to check the settings, the proxy information is correct.  It just isn't being used when downloading the packages.

This worked in F21.

Comment 2 Seth Jennings 2015-03-21 03:01:34 UTC
Looking in the anaconda source as of today (v23.4)

I think the bug is in pyanaconda/packaging/dnfpayload.py in updateBaseRepo() line 705:

base_ksrepo = self.data.RepoData(
    name=constants.BASE_REPO_NAME, baseurl=url,
    mirrorlist=mirrorlist, noverifyssl=not sslverify)
self._add_repo(base_ksrepo)

The corresponding updateBaseRepo() method line 558 in yumpayload.py passes the proxy information here:

self._addYumRepo(BASE_REPO_NAME, url, mirrorlist=mirrorlist,
                                 proxyurl=proxyurl, sslverify=sslverify)


I think that the proxy information is not being written to the repo file.

Comment 3 Seth Jennings 2015-03-22 04:12:39 UTC
Ok, I made a patch and updates.img, based on anaconda-22.20.2-1 that ships with F22 Alpha, that fixes the issue where the packages in the base repo are not downloaded via the proxy.

A.J., I'd be interested if this fix works for you.

Comment 4 Seth Jennings 2015-03-22 04:13:20 UTC
Created attachment 1004991 [details]
updates.img

Comment 5 Seth Jennings 2015-03-22 04:13:53 UTC
Created attachment 1004992 [details]
proxyfix.patch

Comment 6 A.J. Werkman 2015-03-24 19:41:13 UTC
With the updates.img I can install throughout a proxy. Thuis Sems to resolve the problem.

Comment 7 Seth Jennings 2015-03-24 19:45:36 UTC
Pull request filed on github:
https://github.com/rhinstaller/anaconda/pull/46

Comment 8 Fedora Update System 2015-03-26 19:53:47 UTC
anaconda-22.20.7-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/anaconda-22.20.7-1.fc22

Comment 9 Fedora Update System 2015-03-29 05:03:59 UTC
Package anaconda-22.20.7-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-22.20.7-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4952/anaconda-22.20.7-1.fc22
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-03-31 21:42:44 UTC
Package anaconda-22.20.7-1.fc22, libblockdev-0.8-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-22.20.7-1.fc22 libblockdev-0.8-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4952/libblockdev-0.8-1.fc22,anaconda-22.20.7-1.fc22
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2015-04-04 17:52:33 UTC
anaconda-22.20.7-1.fc22, libblockdev-0.8-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 A.J. Werkman 2015-04-08 18:55:58 UTC
In 22 Beta_RC1 I still can not use a proxy.

Comment 13 A.J. Werkman 2015-04-08 19:14:06 UTC
Created attachment 1012382 [details]
Anaconda.log

Comment 14 A.J. Werkman 2015-04-08 19:14:32 UTC
Created attachment 1012383 [details]
Syslog

Comment 15 A.J. Werkman 2015-04-08 19:14:56 UTC
Created attachment 1012384 [details]
Packaing.log

Comment 16 Seth Jennings 2015-04-09 18:52:12 UTC
A.J.,

I just tested proxy operation with Beta RC1 and it works for me.

From your packaging log:
> Failed to connect to mirrors.fedoraproject.org port 443: No route to host

It seems like you might not have network (or internet) connectivity.

Comment 17 A.J. Werkman 2015-04-09 19:55:22 UTC
I already thought about that and checked. I do have network and nameserving functional. I tested this with a request for a local mirror. After your remark I retested with an url to dl.fedoraproject and find that proxy is working. IT looks like there is sommething wrong with the 'closest mirror' option in my test case.

Comment 18 A.J. Werkman 2015-04-09 20:43:50 UTC
Can it be, that there is something wrong with the mirrorlist mechanism behind a proxy.
I see a curl error 'no route to host' and at the same time 'Ping mirroring.fedoraproject.org' resolves to an ip address. Obviously behind the proxy iT Will not ping and without proxy also curl Will fail.

Looks to me that the mirror request does not use the proxy settings.

Comment 19 Brian Lane 2015-04-10 23:00:54 UTC
The mirror list uses https. The mirrors themselves are all http. I don't think proxy will work like you expect unless you've turned off sslverify when using the mirror.

Comment 20 David Shea 2015-05-11 17:54:10 UTC
Just tried with rawhide, and it's working fine, and going through the proxy via CONNECT. No route to host still points to a network or proxy configuration problem.