Bug 1197417

Summary: 'smoothansi 13' offends gimp to death
Product: [Fedora] Fedora Reporter: Dave Kline <dkline>
Component: artwiz-aleczapka-fontsAssignee: Tom "spot" Callaway <tcallawa>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: andreas.bierfert, fonts-bugs, tcallawa
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-03-31 17:55:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Dave Kline 2015-03-01 02:57:53 UTC
Description of problem:
On Fedora 21, Fluxbox pulls the artwiz-aleczapka-smoothansi-fonts rpm as a dependency. Unfortunately having both this package and gimp installed will crash gimp when selecting fonts in gimp's font tool.

Version-Release number of selected component (if applicable):
Name        : artwiz-aleczapka-smoothansi-fonts
Arch        : noarch
Version     : 1.3
Release     : 16.fc21
----
Name        : gimp
Arch        : x86_64
Epoch       : 2
Version     : 2.8.14
Release     : 1.fc21


How reproducible:


Steps to Reproduce:
1. Install gimp and artwiz-aleczapka-smoothansi-fonts
2. In gimp, attempt to change font in text tool 
3. Observe crash

Actual results:


Expected results:


Additional info:
From the console when gimp crashes:
~]$ gimp

(gimp:5845): Pango-WARNING **: failed to create cairo scaled font, expect ugly output. the offending font is 'smoothansi 13'

(gimp:5845): Pango-WARNING **: font_face status is: out of memory

(gimp:5845): Pango-WARNING **: scaled_font status is: out of memory

(script-fu:5856): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error
Segmentation fault (core dumped)
----

Also, I'd opened a bug for gimp before I could narrow the issue: https://bugzilla.redhat.com/show_bug.cgi?id=1195077

Comment 1 Tom "spot" Callaway 2015-03-31 14:16:30 UTC
I can't reproduce this. The internet seems to think this error is sometimes caused by permission errors in ~/.fonts. Also, please make sure you're not running out of disk space.

I'll leave this open for now, but I'd really need a reproducer to troubleshoot it.

Comment 2 Dave Kline 2015-03-31 15:20:50 UTC
Just tried a fresh f21 install via vm and now I cannot reproduce the issue. This may well be an issue with my particular machines. Please feel free to close the issue and I'll reopen if I can recreate it on a fresh setup.

Thanks much for having a look.