Bug 1198267

Summary: Transaction is recommited by joining node during merge
Product: [JBoss] JBoss Data Grid 6 Reporter: Matej ─îimbora <mcimbora>
Component: InfinispanAssignee: Dan Berindei <dberinde>
Status: CLOSED CURRENTRELEASE QA Contact: Martin Gencur <mgencur>
Severity: unspecified Docs Contact:
Priority: medium    
Version: 6.5.0CC: jdg-bugs, pzapataf, rmarwaha, slaskawi
Target Milestone: ER4   
Target Release: 6.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
When a node which was not part of previous view (e.g. due to network partition) joins a cluster, it may request retransmission of previous messages (JGroup's NAKACK). If some of those messages are prepare commands of transactions, which already finished on other nodes, transactions can be prepared & commited on the joining node once again, leading to inconsistent values across the cluster if the affected entries have been modified on nodes from the original view meanwhile. There is no workaround for this issue.
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-06-23 12:25:52 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Matej ─îimbora 2015-03-03 16:57:16 UTC
See related JIRA.

Comment 2 JBoss JIRA Server 2015-05-12 07:43:36 UTC
Dan Berindei <dberinde> updated the status of jira ISPN-5261 to Resolved