Bug 1198577

Summary: Allow subclasses of JGroupsTransport to override the initialization of the rpc dispatcher
Product: [JBoss] JBoss Data Grid 6 Reporter: Sebastian Łaskawiec <slaskawi>
Component: JGroupsAssignee: Tristan Tarrant <ttarrant>
Status: CLOSED CURRENTRELEASE QA Contact: Martin Gencur <mgencur>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.4.0CC: bban, dstahl, pslavice, sjacobs, vjuranek
Target Milestone: ER1   
Target Release: 6.4.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-04-02 12:14:04 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Sebastian Łaskawiec 2015-03-04 12:20:20 UTC
Description of problem:
Since this commit:
https://github.com/infinispan/infinispan/commit/f0fb26d43f0176c165bd10134be7b5feed57c893
... Infinispan is no longer usable in WildFly 9, whose transports are configured to use ForkChannel rather than JChannels. The underlying issue is described in JGRP-1905. The commit above adds a cluster-wide RPC on view change (from org.infinispan.topology.ClusterTopologyManagerImpl.confirmMembersAvailable(), the message for which inevitably arrives on the newly starting node before the requisite fork channel is registered. The RPC eventually times out since Infinispan's RPC dispatcher will wait for a response that will never come.

Comment 2 Sebastian Łaskawiec 2015-03-04 12:33:58 UTC
PR: https://github.com/infinispan/jdg/pull/539