Bug 1199978

Summary: ntpd -x steps clock on leap second
Product: Red Hat Enterprise Linux 6 Reporter: Jan Kurik <jkurik>
Component: ntpAssignee: Miroslav Lichvar <mlichvar>
Status: CLOSED ERRATA QA Contact: qe-baseos-daemons
Severity: high Docs Contact:
Priority: urgent    
Version: 6.6CC: chorn, fkrska, jherrman, john.haxby, mdshaikh, michele, mlichvar, mschuppe, ovasik, pm-eus, psklenar, shin.kusano.ev, shirakata.youko, yozone
Target Milestone: rcKeywords: ZStream
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ntp-4.2.6p5-3.el6_6 Doc Type: Bug Fix
Doc Text:
Previously, when the ntpd daemon was configured with the "-x" option to adjust the system clock slowly instead of changing the time instantaneously, the system clock was incorrectly changed instantaneously when a leap second occurred. In certain applications, this could lead to a variety of system clock related problems, such as incorrect event sorting or triggering. To fix this bug, ntpd now adjusts for the leap second slowly over a long interval, which prevents the described problems.
Story Points: ---
Clone Of: 1190619 Environment:
Last Closed: 2015-03-16 09:07:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1190619    
Bug Blocks:    

Description Jan Kurik 2015-03-09 12:29:57 UTC
This bug has been copied from bug #1190619 and has been proposed
to be backported to 6.6 z-stream (EUS).

Comment 9 errata-xmlrpc 2015-03-16 09:07:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0690.html