Bug 1200401

Summary: Artifacts with invalid OSGi versions in Maven repository zip
Product: [JBoss] JBoss Enterprise Application Platform 6 Reporter: Paul Gier <pgier>
Component: Maven RepositoryAssignee: jboss-set
Status: CLOSED EOL QA Contact: Nikoleta Hlavickova <nziakova>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.4.0   
Target Milestone: CR1   
Target Release: EAP 6.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-19 12:45:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Paul Gier 2015-03-10 13:41:44 UTC
All supported jars have OSGi compliant version in EAP 6.4.0.ER3. However, there are some remaining (not supported) artifacts with invalid OSGi version:

commons-lang-2.6-redhat-2.jar - 2.6-redhat-2
commons-io-2.1-redhat-2.jar - 2.1-redhat-2
relaxngDatatype-2011.1-redhat-3.jar - 2011.1-redhat-3
guava-13.0.1-redhat-1.jar - 13.0.1-redhat-1
mimepull-1.2-redhat-2.jar - 1.2-redhat-2
javassist-3.18.1-GA-redhat-1.jar - 3.18.1-GA-redhat-1
jboss-el-1.0_02.CR5.jar - 1.0_02.CR5
weld-spi-1.1.Final-redhat-5.jar - 1.1.Final-redhat-5
weld-api-1.1.Final-redhat-5.jar - 1.1.Final-redhat-5
rhq-pluginAnnotations-3.0.4-redhat-2.jar - 3.0.4-redhat-2

Could you please confirm that this status is acceptable for layered products?