Bug 1200464

Summary: kde-plasma-smooth-tasks: not compatible with Plasma 5
Product: [Fedora] Fedora Reporter: Kevin Kofler <kevin>
Component: kde-plasma-smooth-tasksAssignee: Sven Lankes <sven>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: urgent    
Version: rawhideCC: rnovacek, sven
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-03-11 13:20:51 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1135103    

Description Kevin Kofler 2015-03-10 15:44:36 UTC
kde-plasma-smooth-tasks as currently shipped in Fedora 22 and Rawhide depends on the Plasma 4 kde-workspace. Therefore, it does not work under the version of the KDE Plasma Desktop workspace shipped with Fedora 22 and higher, which is Plasma 5. (In fact, it does not even install, due to broken dependencies. But even if we were to ship the missing libraries, it would still not work.)

If a Plasma 5 / KDE Frameworks 5 / Qt 5 port exists upstream, please upgrade the package to that version as soon as possible. If not, your best course of action is to retire the non-working package from Fedora 22 and Rawhide as soon as possible (now that it is still possible to retire Fedora 22 packages). (Porting Plasma widgets (plasmoids) from Plasma 4 to Plasma 5 is a significant amount of work and thus not something easily doable downstream. In particular, the user interface now MUST be written in QML 2.) The package can be resurrected once it gets ported upstream.

Thank you for your cooperation.

Comment 1 Fedora Admin XMLRPC Client 2015-03-11 13:00:20 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Sven Lankes 2015-03-11 13:20:51 UTC
There hasn't been any activity in the last two years as far as I can see so I've retired it for 22 and Rawhide. Thanks for the heads up.