Bug 1201789

Summary: Subscriptions page shows list of products minus 1
Product: Red Hat Satellite Reporter: Og Maciel <omaciel>
Component: WebUIAssignee: Katello Bug Bin <katello-bugs>
WebUI sub component: Katello QA Contact: jcallaha
Status: CLOSED ERRATA Docs Contact:
Severity: medium    
Priority: unspecified CC: bbuckingham, jcallaha
Version: 6.1.0Keywords: Triaged
Target Milestone: Unspecified   
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-27 08:49:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Products page
none
Red Hat Subscriptions page
none
foreman-debug
none
Satellite 6.1.1: Products
none
Satellite 6.1.1: Subscriptions none

Description Og Maciel 2015-03-13 14:09:22 UTC
Description of problem:

I noticed that the Red Hat Subscriptions page instead of showing all products for an organization (custom or not), it shows always 1 product less.

The products_page.png screenshot shows that I have 5 products for my Default Organization. However, if I go to the Red Hat Subscriptions page (subscriptions_page.png) I only see 4 products listed.

If I go back to the Products page and add a new one (6th) and go back to the Red Hat Subscriptions page, then I will see 5 total products listed.

Version-Release number of selected component (if applicable):

* Satellite-6.1.0-RHEL-6-20150311.1

How reproducible:


Steps to Reproduce:
1. Visit the Red Hat Subscriptions page and count how many products are listed
2. Add a new custom product through the Products page
3. Go back to the Red Hat Subscriptions page and count how many products are listed

Actual results:

The number of products listed on the Red Hat Subscriptions page is always 1 less than the number of products you have for the org.

Expected results:


Additional info:

Fwiw the very first product I created was via a RH manifest.

Comment 1 Og Maciel 2015-03-13 14:10:05 UTC
Created attachment 1001386 [details]
Products page

Comment 2 Og Maciel 2015-03-13 14:10:41 UTC
Created attachment 1001387 [details]
Red Hat Subscriptions page

Comment 3 RHEL Program Management 2015-03-13 14:23:19 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 5 Og Maciel 2015-03-13 14:59:03 UTC
Saw this:

Mar 13 10:57:16 cloud-qe-18 pulp: gofer.messaging.adapter.qpid.connection:ERROR: connect: qpid+ssl://<SERVER>:5671, failed: [Errno 1] _ssl.c:504: error:14094412:SSL routines:SSL3_READ_BYTES:sslv3 alert bad certificate
Mar 13 10:57:16 cloud-qe-18 pulp: gofer.messaging.adapter.qpid.connection:INFO: retry in 106 seconds

Comment 6 Og Maciel 2015-03-13 15:00:29 UTC
==> /var/log/messages <==
Mar 13 10:57:16 cloud-qe-18 qpidd: 2015-03-13 10:57:16 [System] error Error reading socket: Success(0)
Mar 13 10:57:16 cloud-qe-18 qpidd[25183]: 2015-03-13 10:57:16 [System] error Error reading socket: Success(0)
Mar 13 10:57:16 cloud-qe-18 pulp: gofer.messaging.adapter.qpid.connection:ERROR: connect: qpid+ssl://<SERVER>:5671, failed: [Errno 1] _ssl.c:504: error:14094412:SSL routines:SSL3_READ_BYTES:sslv3 alert bad certificate
Mar 13 10:57:16 cloud-qe-18 pulp: gofer.messaging.adapter.qpid.connection:INFO: retry in 106 seconds

Comment 7 Og Maciel 2015-03-13 16:12:24 UTC
Created attachment 1001439 [details]
foreman-debug

Comment 8 Brad Buckingham 2015-09-10 15:08:38 UTC
I have tested this on a Satellite 6.1.1 GA install and am no longer observing
the behavior described.

RPMs installed:
  ruby193-rubygem-katello-2.2.0.66-1.el7sat.noarch
  foreman-1.7.2.34-1.el7sat.noarch

Attaching updated screenshot.  Note: 'DeleteMe' is a custom product that I added with no repositories.

Comment 9 Brad Buckingham 2015-09-10 15:09:12 UTC
Created attachment 1072247 [details]
Satellite 6.1.1: Products

Comment 10 Brad Buckingham 2015-09-10 15:09:41 UTC
Created attachment 1072248 [details]
Satellite 6.1.1: Subscriptions

Comment 11 jcallaha 2015-10-29 18:39:14 UTC
Verified in upstream. I am consistently seeing all subscriptions expected on the subscriptions page. This includes Red Hat and custom subscriptions.

 HOSTNAME: rhsm-qe-1.rhq.lab.eng.bos.redhat.com
       OS: redhat
  RELEASE: Red Hat Enterprise Linux Server release 7.1 (Maipo)
  FOREMAN: 1.11.0-develop
     RUBY: ruby 2.0.0p598 (2014-11-13) [x86_64-linux]
   PUPPET: 3.8.3
  DENIALS: 0

Comment 14 errata-xmlrpc 2016-07-27 08:49:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500