Bug 1203057

Summary: no ld.gold on aarch64
Product: [Fedora] Fedora Reporter: Jens Petersen <petersen>
Component: binutilsAssignee: Nick Clifton <nickc>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: rawhideCC: jakub, nickc, pbrobinson
Target Milestone: ---   
Target Release: ---   
Hardware: aarch64   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-06-11 07:40:19 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 922257, 1195231    
Attachments:
Description Flags
conftest.c for "AC_CHECK_SIZEOF(long long, 8)" none

Description Jens Petersen 2015-03-18 03:00:06 UTC
Description of problem:
Please enable ld.gold on aarch64.

Scratch build with:

%define gold_arches %ix86 x86_64 %arm aarch64

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=2924943

Comment 1 Jens Petersen 2015-04-21 10:25:54 UTC
It turns out ld.gold is needed for correct ghc linking on aarch64.

So could you please enable it soon for f22 and f23?

If time is an issue I can also do it - thanks!

Comment 2 Nick Clifton 2015-04-21 16:27:16 UTC
Hi Jens,

  The new 2.25-7 binutils rpm in rawhide enables support for building GOLD for AArch64.  Please give it a go and let me know if you encounter any problems.

  Has the f23 branch been created yet ?  I could not see it.

Cheers
  Nick

Comment 3 Nick Clifton 2015-04-21 16:43:13 UTC
 binutils-2.25-6.fc2 now also contains this patch.

Comment 4 Peter Robinson 2015-04-21 17:05:13 UTC
>   Has the f23 branch been created yet ?  I could not see it.

F-23 is the master branch

Comment 5 Jens Petersen 2015-04-24 10:12:57 UTC
(In reply to Nick Clifton from comment #2)
>   The new 2.25-7 binutils rpm in rawhide enables support for building GOLD
> for AArch64.  Please give it a go and let me know if you encounter any
> problems.

Thanks!  That is basically what I tested already locally.


On aarch64 using -fuse-ld=gold seems to break:

AC_CHECK_SIZEOF(long long,          8)

Comment 6 Jens Petersen 2015-04-24 10:16:19 UTC
Created attachment 1018372 [details]
conftest.c for "AC_CHECK_SIZEOF(long long, 8)"

checking size of long long... configure: error: in `/builddir/build/BUILD/ghc-7.10.1.20150414':
configure: error: cannot compute sizeof (long long)


$ gcc -o conftest conftest.c
$ ./conftest
$ gcc -o conftest -fuse-ld=gold conftest.c
$ ./conftest
Killed
$ 


(gdb) r
Starting program: /home/petersen/conftest 
During startup program terminated with signal SIGKILL, Killed.

Comment 7 Jens Petersen 2015-04-24 10:24:41 UTC
I can open a separate bug for AC_CHECK_SIZEOF(long long, 8).

Comment 8 Nick Clifton 2015-04-24 12:34:24 UTC
Hi Jens,

> I can open a separate bug for AC_CHECK_SIZEOF(long long, 8).

Please do.

Presumably gold is at fault, but it would be helpful if you could capture the command line used to invoke gold, as well as the object file that it is trying to link.

Cheers
  Nick

Comment 9 Jens Petersen 2015-04-27 05:57:48 UTC
Okay I filed bug 1215546.

Comment 10 Jens Petersen 2015-05-21 03:37:15 UTC
I guess this could be closed now: ld.gold is in F23 Rawhide