Bug 1204149

Summary: [BUG] Statistics only report for "All Hosts" and not "Content Hosts"
Product: Red Hat Satellite Reporter: Alexander von Gluck IV <kallisti5>
Component: HostsAssignee: Ohad Levy <ohadlevy>
Status: CLOSED ERRATA QA Contact: jcallaha
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.0.8CC: bbuckingham, cwelton, jcallaha
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-27 08:49:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
missing statistics
none
present content hosts none

Description Alexander von Gluck IV 2015-03-20 13:38:39 UTC
The charts in statistics reference:
  /hosts?search=os_description=~VAL1~

That only contains "all hosts" and not "content hosts".

As we have no "all hosts", all the charts are blank.

Comment 1 Alexander von Gluck IV 2015-03-20 13:41:42 UTC
Created attachment 1004505 [details]
missing statistics

Comment 2 Alexander von Gluck IV 2015-03-20 13:42:01 UTC
Created attachment 1004506 [details]
present content hosts

Comment 3 RHEL Program Management 2015-03-20 13:43:03 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 5 Brad Buckingham 2016-02-26 19:03:10 UTC
One of the features being introduced as part of Satellite 6.2, is "Host Unification".  It is basically the unification of the Host and Content Host.  With this feature, for any content host that gets created, there will always be an associated host (as the content is just a 'facet' of the host).  This means that as far as statistics are concerned, any applicable statistics will be included.  That said, for a base content host that doesn't have puppet, this may be fairly limited (e.g. only OS and arch).

Comment 7 jcallaha 2016-04-14 19:46:04 UTC
Verified in Satellite 6.2 Beta Snap 8 Compose 1. All applicable statistics are now reported for content hosts.

Comment 9 errata-xmlrpc 2016-07-27 08:49:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500