Bug 1207872

Summary: If the first DB role deployment fails, so will all future roles
Product: [Fedora] Fedora Reporter: Stephen Gallagher <sgallagh>
Component: rolekitAssignee: Thomas Woerner <twoerner>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 22CC: awilliam, robatino, sgallagh, tflink, twoerner
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: RejectedBlocker AcceptedFreezeException
Fixed In Version: rolekit-0.3.2-1.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-04-17 02:29:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1043128    

Description Stephen Gallagher 2015-03-31 23:34:13 UTC
Description of problem:
Right now, the DB role only checks whether another instance exists. We should check whether it exists and is in ready-to-start or running state.
Otherwise, the subsequent deployments won't initialize the database and will fail to start the service.

Version-Release number of selected component (if applicable):
rolekit-0.3.0-1.fc22

How reproducible:
Every time

Steps to Reproduce:
1. Update rolekit on a system without existing database role instances.
2. Run 'rolectl deploy databaseserver' (note the lack of --settings-file containing necessary minimum settings)
3. Run 'rolectl deploy databaseserver --settings-file=valid.json' with valid setting values.

Actual results:
Role deployment fails with an error. Subsequent database server role deployments with correct settings fail with an error attempting to start the postgresql service.


Expected results:
Role deployment fails with an error. Subsequent deployments with correct settings should behave correctly.


Additional info:

Comment 1 Fedora Blocker Bugs Application 2015-03-31 23:39:12 UTC
Proposed as a Blocker for 22-beta by Fedora user sgallagh using the blocker tracking app because:

 "The core functional requirements for all Featured Server Roles must be met, without any workarounds being necessary."
From the DB role core functional requirements:
"A deployed Database Server must provide a PostgreSQL instance which will serve requests from the local system on port 5432."

Comment 2 Fedora Update System 2015-03-31 23:40:16 UTC
rolekit-0.3.1-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-4922/rolekit-0.3.1-1.fc22

Comment 3 Fedora Update System 2015-04-02 01:44:53 UTC
Package rolekit-0.3.1-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rolekit-0.3.1-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4922/rolekit-0.3.1-1.fc22
then log in and leave karma (feedback).

Comment 4 Adam Williamson 2015-04-03 01:36:16 UTC
This feels borderline blocker to me; I suspect if we found it the day of go/no-go we'd handwave it. So I'm gonna vote -1 blocker, +1 FE. We would say something like 'oh, well, it works if you do it right!'

Comment 5 Tim Flink 2015-04-03 01:42:27 UTC
Yeah, it sounds more FE than blocker to me - especially for beta.

-1 blocker, +1 FE

Comment 6 Dennis Gilmore 2015-04-03 01:50:03 UTC
-1 Blocker, +1 FE

Comment 7 Adam Williamson 2015-04-03 01:56:42 UTC
-3 blocker +3 FE, marking appropriately.

Comment 8 Fedora Update System 2015-04-08 18:37:17 UTC
Package rolekit-0.3.2-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rolekit-0.3.2-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4922/rolekit-0.3.2-1.fc22
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-04-17 02:29:42 UTC
rolekit-0.3.2-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.