Bug 1207881

Summary: etcd-v2.0.8 is available
Product: [Fedora] Fedora Reporter: Upstream Release Monitoring <upstream-release-monitoring>
Component: etcdAssignee: Luke Cypret <lacypret>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: eparis, golang-updates, jchaloup, lacypret, lemenkov, lsm5, walters
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: etcd-2.0.8-0.1.fc22 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-04-21 18:26:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Upstream Release Monitoring 2015-04-01 00:25:11 UTC
Latest upstream release: v2.0.8
Current version/release in rawhide: 2.0.7-0.1.fc23
URL: https://github.com/coreos/etcd

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Comment 1 Upstream Release Monitoring 2015-04-01 00:25:24 UTC
Failed to kick off scratch build.

cmd:  spectool -g /var/tmp/thn-crYHCH/etcd.spec
return code:  22
stdout:
Getting https://github.com/coreos/etcd/archive/vv2.0.8.tar.gz to ./vv2.0.8.tar.gz

stderr:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   120    0   120    0     0    206      0 --:--:-- --:--:-- --:--:--   206

  0     0    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found

Comment 2 Lokesh Mandvekar 2015-04-01 04:02:09 UTC
Looks like Upstream Release Monitoring tries to get %{version} from "Latest upstream release: v2.0.8", and that's why the vv2.0.8. Though Source0 URL in spec file looks like it'll fetch the correct tarball.

Also, given that we now have numbered releases, the release tag shouldn't have 0.N any longer. The NVR can now be etcd-2.0.8-1 moving forward

Comment 3 Fedora Update System 2015-04-01 08:20:08 UTC
etcd-2.0.8-0.1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/etcd-2.0.8-0.1.fc22

Comment 4 Fedora Update System 2015-04-01 08:24:59 UTC
etcd-2.0.8-0.1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/etcd-2.0.8-0.1.fc21

Comment 5 Fedora Update System 2015-04-01 08:25:27 UTC
etcd-2.0.8-0.1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/etcd-2.0.8-0.1.fc20

Comment 7 Fedora Update System 2015-04-01 22:24:44 UTC
Package etcd-2.0.8-0.1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing etcd-2.0.8-0.1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5213/etcd-2.0.8-0.1.fc21
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2015-04-21 18:26:18 UTC
etcd-2.0.8-0.1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2015-04-21 18:27:19 UTC
etcd-2.0.8-0.1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2015-04-21 18:57:13 UTC
etcd-2.0.8-0.1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.