Bug 1208755

Summary: update the current version of Yad to 0.28.1
Product: [Fedora] Fedora Reporter: David Vásquez <davidjeremias82>
Component: yadAssignee: Elder Marco <eldermarco>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: davidjeremias82, eldermarco
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: yad-0.28.1-1.fc21 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-04-18 09:42:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description David Vásquez 2015-04-03 05:44:18 UTC
Description of problem:

Please update the current version of Yad to 0.28.1



Additional info:

The current version fixed some bugs; and includes new features.

Version 0.28.1
    - fix incorrect rows output order in form dialog

Version 0.28.0
    - add HTML dialog
    - add different output formats for color dialog
    - add mnemonic feature for field labels in form and entry dialogs
    - add completion entry as field type in form dialog
    - add output by rows in form dialog when layout with several columns is used
    - fix labels in multiprogress dialog
    - fix print to file in print dialog
    - fix setup arguments for double-click action in list dialog
    - update man page

Sources: http://sourceforge.net/projects/yad-dialog/files/

Comment 1 David Vásquez 2015-04-04 02:51:23 UTC
I rebuilt the src.rpm of rawhide (F22) into F21 "yad-0.28.1-1.fc22.src.rpm"; and doesn't work because present a conflict with gtk3; then I changed enable gtk3 only for F22 and latest, and worked fine.


%if 0%{?fedora} >= 22 || 0%{?rhel} >= 7
%configure --enable-icon-browser --enable-html --with-gtk=gtk3
%else
%configure --enable-icon-browser --enable-html --with-gtk=gtk2
%endif

Comment 2 Elder Marco 2015-04-05 15:22:50 UTC
Hi there,

You need to install the dependencies in order to build yad:

# dnf builddep yad.spec

And run rpmbuild:

$ rpmbuild -bb yad.spec


Anyway, I will update this package. No problem :)

Comment 3 Fedora Update System 2015-04-05 15:41:31 UTC
yad-0.28.1-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/yad-0.28.1-1.fc21

Comment 4 Elder Marco 2015-04-05 15:45:46 UTC
Done! The package will be available in updates-testing soon :)

Comment 5 Fedora Update System 2015-04-06 08:34:58 UTC
Package yad-0.28.1-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yad-0.28.1-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5635/yad-0.28.1-1.fc21
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-04-18 09:42:31 UTC
yad-0.28.1-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.