Bug 1211324

Summary: OFI configure logrotate for pacemaker
Product: Red Hat OpenStack Reporter: Randy Perryman <randy_perryman>
Component: openstack-foreman-installerAssignee: Jason Guiditta <jguiditt>
Status: CLOSED DUPLICATE QA Contact: Ami Jeain <ajeain>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.0 (Juno)CC: jguiditt, lnatapov, mburns, morazi, rhos-maint, yeylon
Target Milestone: ---Keywords: Triaged, ZStream
Target Release: Installer   
Hardware: All   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1120208 Environment:
Last Closed: 2015-04-13 16:29:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1120208    
Bug Blocks:    

Description Randy Perryman 2015-04-13 15:38:03 UTC
See the same thing using OpenStack Foreman Installer

+++ This bug was initially created as a clone of Bug #1120208 +++

The log level and the retry interval on pacemaker should be turned down. The log growth and fills up the disk.

-rw-rw----. 1 hacluster haclient 4.8G Jul 16 08:01 pacemaker.log

I think it grew because the glance mount failed and it kept retrying to mount. So with correct params it shouldn't grow that fast.We probably shouldn't retry the mount N times per second, but maybe once per a few seconds. In any case we should rotate the log.

--- Additional comment from Mike Burns on 2014-09-23 11:02:23 EDT ---

Should this logrotate be done on the pacemaker level or through puppet?

--- Additional comment from Jason Guiditta on 2014-09-23 12:24:25 EDT ---

Even though the subject is logrotate, the description actually asks for setting logging level and retry interval for pacemaker, which sounds like something we should be able to set from quickstack.  However, after a quick look, I don't see anywhere that it can be set via puppet-pacemaker.  So, this would need to be added there, and then we could call it from quickstack easily enough.

--- Additional comment from Mike Burns on 2014-09-24 14:55:14 EDT ---

Yes, the text asks for log level control, but even if we lowered the level, it would still grow in this case.  The log filled with glance mount errors.  Errors won't ever be rotated out.  

We should instead rotate the log file which will prevent the log from growing so big.

Comment 5 Mike Burns 2015-04-13 16:29:12 UTC
The referenced bug is already against OFI.

*** This bug has been marked as a duplicate of bug 1120208 ***