Bug 1212061

Summary: VLAN options in ifcfg file for CTC device
Product: [Fedora] Fedora Reporter: Jan Stodola <jstodola>
Component: dracutAssignee: dracut-maint-list
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 22CC: dracut-maint-list, harald, jonathan, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: s390x   
OS: Linux   
Whiteboard:
Fixed In Version: dracut-041-10.fc22.1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-04-26 12:57:04 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 467765    
Attachments:
Description Flags
journalctl from installation with rd.debug none

Description Jan Stodola 2015-04-15 13:32:03 UTC
Description of problem:
ifcfg config file created for a CTC (channel-to-channel) network device contains VLAN options:

# Generated by dracut initrd
NAME="slccw0.0.d000"
SUBCHANNELS="0.0.d000,0.0.d001"
NETTYPE="ctc"
OPTIONS="protocol=0"
DEVICE="slccw0.0.d000"
ONBOOT=yes
NETBOOT=yes
UUID="4b28b6f4-f6de-4778-b8b3-ac0f136da891"
BOOTPROTO=none
IPADDR="192.168.1.2"
PREFIX="32"
GATEWAY="192.168.1.1"
TYPE=Vlan                   # these options
NAME="slccw0.0.d000"        # shouldn't be 
VLAN=yes                    # written to the
PHYSDEV=""                  # config file
DNS1="10.16.36.29"
DNS2="10.11.5.19"


Version-Release number of selected component (if applicable):
dracut-041-10.fc22.s390x.rpm

How reproducible:
always

Steps to Reproduce:
1. install F22/s390x via CTC network device

Actual results:
VLAN options in ifcfg file

Expected results:
VLAN options not written to ifcfg file

Comment 1 Jan Stodola 2015-04-15 13:33:14 UTC
Created attachment 1014755 [details]
journalctl from installation with rd.debug

Comment 2 Jan Stodola 2015-04-15 13:34:04 UTC
This patch works for me:

diff --git a/modules.d/45ifcfg/write-ifcfg.sh b/modules.d/45ifcfg/write-ifcfg.sh
index 3dcf304..f5de788 100755
--- a/modules.d/45ifcfg/write-ifcfg.sh
+++ b/modules.d/45ifcfg/write-ifcfg.sh
@@ -137,6 +137,7 @@ for netup in /tmp/net.*.did-setup ; do
     unset macaddr
     unset slave
     unset ethname
+    unset vlan
     [ -e /tmp/bond.${netif}.info ] && . /tmp/bond.${netif}.info
 
     uuid=$(cat /proc/sys/kernel/random/uuid)

Comment 4 Fedora Update System 2015-04-21 13:57:15 UTC
dracut-041-10.fc22.1 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dracut-041-10.fc22.1

Comment 5 Fedora Update System 2015-04-22 22:53:07 UTC
Package dracut-041-10.fc22.1:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-041-10.fc22.1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-6659/dracut-041-10.fc22.1
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-04-26 12:57:04 UTC
dracut-041-10.fc22.1 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.