Bug 1217333

Summary: RFE: Prevent large strings from disrupting the page layout (eg too many components)
Product: [Community] Bugzilla Reporter: Sean Flanigan <sflaniga>
Component: User InterfaceAssignee: PnT DevOps Devs <hss-ied-bugs>
Status: CLOSED CURRENTRELEASE QA Contact: tools-bugs <tools-bugs>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.4CC: jfearn, jmcdonal, mtahir, qgong, sflaniga
Target Milestone: ---Keywords: UserExperience
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-12-17 00:57:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1211440    

Description Sean Flanigan 2015-04-30 07:33:36 UTC
If even one of the bugs in a list of search results has too many components, the Components column becomes too wide and pushes all the other columns out of the visible area.  I think this actually applies to a lot of fields (eg Summary), but Components tends to be one of the worst offenders because one bug may have a single component, and another may have six.

We need a better way of displaying results which won't let the entire page layout be ruined by one cell.  For instance:

1. Truncate the cell contents with an ellipsis, and add a tool-tip with the full
contents.  The truncation limit might be say 150% of the average component name, or some other rule of thumb.

2. Or shrink the font for that cell until the text fits (or a
minimum font size is reached)!  

3. Or something far better thought up by a designer.  I'm not a magician, Spock, just an old country doctor^W programmer.

Comment 1 Jeff Fearn 🐞 2015-12-14 22:54:09 UTC
Hi Sean, is this still a problem with the new component widget?

Comment 2 Sean Flanigan 2015-12-16 02:41:43 UTC
The component field looks fine now that it wraps to multiple lines. Thanks!