Bug 1217768

Summary: [abrt] dnf: tracer.py:59:transaction:NameError: global name 'installed' is not defined
Product: [Fedora] Fedora Reporter: Joe Julian <joe>
Component: dnf-plugins-extrasAssignee: Igor Gnatenko <ignatenko>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 21CC: ageha.stg, ahumada.enzo, akozumpl, allinux4, apo, code, danofsatx, duvelle.jones, edosurina, EGriffith92, extras-qa, fedora, fedora, gabriel.schubiner, George.Nikandrov, gtwilliams, hark110, ignatenko, iorlov89, iweiss, jirinek, jkadlcik, joe, jonandmykaela, jsilhan, legunt, liblit, mastaizawfm, maxime.tierre, mluscon, mschmidt, mtk, nightromantic, orti1980, packaging-team-maint, panospolychronis, pblaho, pnemade, rabin, red, revjdc, rholy, rnfano2, rocketraman, Simon.Gerhards, stefano.manocchio, synchris, thovensantos, tla, vlad, vmukhame, wdh
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
URL: https://retrace.fedoraproject.org/faf/reports/bthash/ad5ecd0d42f905535fc507f8edf7c146e0aeb3af
Whiteboard: abrt_hash:699fef4af81794ebefb9bd0a012acb2fa1c23acc
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1187763 Environment:
Last Closed: 2015-07-22 09:49:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Joe Julian 2015-05-01 15:10:29 UTC
Cloning as this was erroneously closed with a patch to f22 even though the bug is for f21. Please backport. 

+++ This bug was initially created as a clone of Bug #1187763 +++

Version-Release number of selected component:
dnf-0.6.3-2.fc21

Additional info:
reporter:       libreport-2.3.0
cmdline:        /usr/bin/python -OO /bin/dnf install couchdb
dso_list:       dnf-plugins-extras-tracer-0.0.3-1.fc21.noarch
executable:     /bin/dnf
kernel:         3.18.3-201.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
tracer.py:59:transaction:NameError: global name 'installed' is not defined

Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 182, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 141, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 160, in resolving
    base.do_transaction()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 221, in do_transaction
    self.plugins.run_transaction()
  File "/usr/lib/python2.7/site-packages/dnf/plugin.py", line 82, in fn
    dnf.util.mapall(operator.methodcaller(method), self.plugins)
  File "/usr/lib/python2.7/site-packages/dnf/util.py", line 157, in mapall
    return list(map(fn, *seq))
  File "/usr/lib/python2.7/site-packages/dnf-plugins/tracer.py", line 59, in transaction
    args = ["tracer", "-n"] + list(installed | erased)
NameError: global name 'installed' is not defined

Local variables in innermost frame:
self: <dnf.plugin.dynamic.tracer.Tracer object at 0x7fb3f4e1ccd0>

--- Additional comment from Ingo Weiss on 2015-01-30 15:00:51 EST ---



--- Additional comment from Ingo Weiss on 2015-01-30 15:00:52 EST ---



--- Additional comment from Radek Holy on 2015-02-02 03:12:57 EST ---

I'm pretty sure that this is a bug in dnf-plugins-extras.

--- Additional comment from Radek Holy on 2015-02-13 09:59:18 EST ---



--- Additional comment from Igor Gnatenko on 2015-02-13 10:07:07 EST ---

Thanks for report.

Fixed in master branch.

https://github.com/rpm-software-management/dnf-plugins-extras/commit/379b051cc06f61124b19329d093f140bf8e05e3f

--- Additional comment from James Begley on 2015-02-20 14:01:32 EST ---

I'm still getting this error with dnf-plugins-extras 0.0.4

[root@purplevaio james]# rpm -qa | grep dnf
dnf-0.6.4-1.fc21.noarch
dnf-plugins-extras-common-0.0.4-1.fc21.noarch
dnf-plugins-core-0.1.5-1.fc21.noarch
dnf-plugins-extras-tracer-0.0.4-1.fc21.noarch

Traceback (most recent call last):
  File "/usr/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 182, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 141, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 160, in resolving
    base.do_transaction()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 221, in do_transaction
    self.plugins.run_transaction()
  File "/usr/lib/python2.7/site-packages/dnf/plugin.py", line 82, in fn
    dnf.util.mapall(operator.methodcaller(method), self.plugins)
  File "/usr/lib/python2.7/site-packages/dnf/util.py", line 157, in mapall
    return list(map(fn, *seq))
  File "/usr/lib/python2.7/site-packages/dnf-plugins/tracer.py", line 59, in transaction
    args = ["tracer", "-n"] + list(installed | erased)
NameError: global name 'installed' is not defined

--- Additional comment from Fedora Update System on 2015-02-27 08:15:38 EST ---

dnf-plugins-extras-0.0.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.5-1.fc22

--- Additional comment from Fedora Update System on 2015-02-27 14:44:15 EST ---

Package dnf-plugins-extras-0.0.5-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-extras-0.0.5-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2793/dnf-plugins-extras-0.0.5-2.fc22
then log in and leave karma (feedback).

--- Additional comment from Olivier Samyn on 2015-02-28 11:04:47 EST ---

This has been pushed to fedora 22 testing, but the problem has been reported, and still occurs on fedora 21.

--- Additional comment from Fedora Update System on 2015-02-28 11:41:39 EST ---

Package dnf-plugins-extras-0.0.5-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-extras-0.0.5-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2793/dnf-plugins-extras-0.0.5-3.fc22
then log in and leave karma (feedback).

--- Additional comment from Fedora Update System on 2015-03-22 00:29:26 EDT ---

Package dnf-plugins-extras-0.0.5-4.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-extras-0.0.5-4.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2793/dnf-plugins-extras-0.0.5-4.fc22
then log in and leave karma (feedback).

--- Additional comment from Raman Gupta on 2015-03-23 20:03:19 EDT ---

Is this going to be backported to F21?

--- Additional comment from Radek Holy on 2015-04-07 06:19:44 EDT ---



--- Additional comment from Jakub Kadlčík on 2015-04-07 08:54:56 EDT ---

> Is this going to be backported to F21?

I hope so, but @ignatenkobrain says that fixed version of dnf-plugin-extras needs newer version of DNF. I don't know how big the problem it is.

--- Additional comment from Fedora Update System on 2015-04-21 15:10:46 EDT ---

dnf-plugins-extras-0.0.5-4.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from Olivier Samyn on 2015-04-21 15:53:55 EDT ---

From the bug report description:

Product: 	Fedora
Component: 	dnf-plugins-extras (Show other bugs)
Version: 	21

This has been solved on fedora 22 not 21; so the problem is not solved and bug should not be closed.

--- Additional comment from Christian Stadelmann on 2015-04-28 16:40:42 EDT ---

Same here. This bug still happens most times dnf with plugin tracer runs. Just look at the graph: https://retrace.fedoraproject.org/faf/reports/552490/

Comment 1 Honza Silhan 2015-07-22 09:49:46 UTC

*** This bug has been marked as a duplicate of bug 1213964 ***