Bug 1218760

Summary: firewall applet icon does not appear in Plasma 5 system tray
Product: [Fedora] Fedora Reporter: Gerald Cox <gbcox>
Component: firewalldAssignee: Thomas Woerner <twoerner>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 22CC: ed.greshko, germano.massullo, jpopelka, kevin, laurent.rineau__fedora, rdieter, twoerner
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: https://github.com/t-woerner/firewalld/issues/23
Whiteboard:
Fixed In Version: firewalld-0.3.14.2-2.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-06-24 16:04:46 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Gerald Cox 2015-05-05 19:14:47 UTC
Description of problem:
icon does not appear in notification area for plasma 5

Version-Release number of selected component (if applicable):
firewall-applet-0.3.13-5.fc22.noarch

How reproducible:
start firewall-applet

Steps to Reproduce:
1. firewall-applet
2.
3.

Actual results:
No icon in notification area

Expected results:
icon in notification area

Additional info:
Output from console:
firewall-applet
/bin/firewall-applet:375: Warning: The property GtkSettings:gtk-menu-images is deprecated and shouldn't be used anymore. It will be removed in a future version.
  Gtk.IconSize.MENU))
/bin/firewall-applet:405: Warning: The property GtkImageMenuItem:use-stock is deprecated and shouldn't be used anymore. It will be removed in a future version.
  item = Gtk.ImageMenuItem.new_from_stock(Gtk.STOCK_ABOUT, None)
/bin/firewall-applet:405: Warning: The property GtkImageMenuItem:accel-group is deprecated and shouldn't be used anymore. It will be removed in a future version.
  item = Gtk.ImageMenuItem.new_from_stock(Gtk.STOCK_ABOUT, None)
/usr/lib64/python2.7/site-packages/gi/overrides/Gtk.py:567: Warning: The property GtkSettings:gtk-button-images is deprecated and shouldn't be used anymore. It will be removed in a future version.
  self.add_button(text, response)

Comment 1 Rex Dieter 2015-05-07 02:49:16 UTC
It probably won't work if it uses standard Gtk systray icon apis, which lack support for Status Notifiers (or Ayatana indicators).  One thing that would help is if firewall-applet used python-appindicator

Comment 2 Rex Dieter 2015-05-07 02:53:05 UTC
See also this post made awhile back during F-22 development,
https://lists.fedoraproject.org/pipermail/devel/2014-March/196343.html

Comment 3 Gerald Cox 2015-05-07 03:31:52 UTC
I double checked and found where firewalld is the default firewall solution
for Fedora:

https://fedoraproject.org/wiki/Features/firewalld-default

Comment 4 Thomas Woerner 2015-06-03 10:07:24 UTC
Reported upstream: https://github.com/t-woerner/firewalld/issues/23

Comment 5 Thomas Woerner 2015-06-09 14:57:40 UTC
Here is a new firewall-applet using Qt in the qt-gui branch of firewalld:

https://raw.githubusercontent.com/t-woerner/firewalld/qt-gui/src/firewall-applet-qt

Comment 6 Gerald Cox 2015-06-09 17:45:41 UTC
Excellent.  Works for me, here is what I did to test:

1.  Downloaded the file in comment #5

Following commands as root:

2.  cp /usr/bin/firewall-applet /usr/bin/firewall-applet-gnome
3.  cp firewall-applet-qt /usr/bin/firewall-applet
4.  chown root firewall-applet
5.  chmod 755 firewall-applet

Comment 7 Ed Greshko 2015-06-15 12:00:10 UTC
firewall-applet.noarch 0.3.14.1-1.fc22 appears to fix this BZ

Comment 8 Ed Greshko 2015-06-15 12:37:09 UTC
This is odd....  I installed firewall-applet.noarch 0.3.14.1-1.fc22 on one system and it is working fine.  While on a second system I'm getting this error.

[egreshko@f22k ~]$ firewall-applet 
Traceback (most recent call last):
  File "/bin/firewall-applet", line 24, in <module>
    from PyQt4 import QtGui, QtCore
ImportError: No module named PyQt4

What could be the difference?

Comment 9 Rex Dieter 2015-06-15 12:52:07 UTC
presumably, missing dependency.

Do you have PyQt4 or python3-PyQt4 installed on the second (non-working) system?

I think the .spec may have some faulty logic:

%if 0%{?with_python3}
Requires: python3-PyQt4
Requires: python3-gobject
%else
Requires: PyQt4
Requires: pygobject3-base
%endif

I think the 0%{?with_python3} should be 0%{?use_python3}

Comment 10 Rex Dieter 2015-06-15 13:03:00 UTC
Confirmed, 

$ rpm -q firewall-applet
firewall-applet-0.3.14.1-1.fc22 

$ head -1 /usr/bin/firewall-applet
#!/usr/bin/python -Es

but it's PyQt4-related deps want python3:

$ rpm -qR firewall-applet | grep PyQt
python3-PyQt4

Comment 11 Ed Greshko 2015-06-15 13:57:58 UTC
PyQt4 was not installed.  I checked the logs on the working system and it was pulled in but not so on the non-working system.  Installing it did fix it.  Thanks.

Comment 12 Ed Greshko 2015-06-15 14:04:20 UTC
On thinking about it I think there was a difference between the two systems.  The working system had firewall-applet.noarch 0.3.13-7.fc22 already installed so that this was an "upgrade" while the non-working system did not have any firewall-applet installed.

Comment 13 Fedora Update System 2015-06-17 12:49:35 UTC
firewalld-0.3.14.2-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/firewalld-0.3.14.2-1.fc22

Comment 14 Fedora Update System 2015-06-21 00:10:55 UTC
Package firewalld-0.3.14.2-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firewalld-0.3.14.2-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10297/firewalld-0.3.14.2-2.fc22
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2015-06-24 16:04:46 UTC
firewalld-0.3.14.2-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.