Bug 1219033

Summary: Utility detection broken with the cs_CZ (Czech) locale
Product: [Fedora] Fedora Reporter: Martin Kolman <mkolman>
Component: libblockdevAssignee: Vratislav Podzimek <vpodzime>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 22CC: danofsatx, erzentd, mkolman, robatino, sbueno, vpodzime
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: RejectedBlocker AcceptedFreezeException
Fixed In Version: libblockdev-0.13-1.fc22 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-05-19 00:00:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1043132    

Description Martin Kolman 2015-05-06 12:49:48 UTC
Description of problem:
The libblockdev utility detection does not work correctly with non-English locales, such as with the Czech (cs_CZ locale). This breaks libblockdev and all other libraries and dependent applications, such as Initial Setup, when using a non-English locale.

How reproducible:
always


Steps to Reproduce:
1. start F22 installation from latest compose
2. select the XFCE environment and don't create a user

Actual results:
Initial Setup is not started, running "journalctl -u initial-setup-graphical" reveals that it crashed during Blivet/libblockdev initialization.

Expected results:
Initial Setup is started and can be used to create the user account.

Comment 1 Fedora Blocker Bugs Application 2015-05-06 13:17:51 UTC
Proposed as a Blocker for 22-final by Fedora user m4rtink using the blocker tracking app because:

 This bug breaks Initial Setup, which is used after the installation on the release blocking KDE spin.

Comment 2 Vratislav Podzimek 2015-05-06 13:19:21 UTC
Already fixed on master, just needs a new release and build.

Comment 3 Dan Mossor [danofsatx] 2015-05-11 19:31:14 UTC
Discussed at the 2015-05-11 blocker review meeting[0]. Voted as RejectedBlocker AcceptedFreezeException.

#agreed 1219033 - RejectedBlocker AcceptedFreezeException - i-s isn't actually critical as you can log in as root on all spins where it's intended to appear, but obviously this should be fixed as we want it to appear

[0]: http://meetbot.fedoraproject.org/fedora-blocker-review/2015-05-11/

Comment 4 Fedora Update System 2015-05-13 10:55:13 UTC
libblockdev-0.13-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/libblockdev-0.13-1.fc22

Comment 5 Martin Kolman 2015-05-14 12:49:42 UTC
*** Bug 1221593 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2015-05-14 22:21:43 UTC
Package libblockdev-0.13-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libblockdev-0.13-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8224/libblockdev-0.13-1.fc22
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2015-05-19 00:00:30 UTC
libblockdev-0.13-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.