Bug 12194

Summary: Ananconda Error on install using latest image files
Product: [Retired] Red Hat Linux Reporter: danmcnaul
Component: installerAssignee: Brock Organ <borgan>
Status: CLOSED WORKSFORME QA Contact: Brock Organ <borgan>
Severity: high Docs Contact:
Priority: high    
Version: 6.2CC: danmcnaul
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-08-17 11:54:22 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
rpm -qai run of RedHat v6.1 installed components. (updates applied) none

Description danmcnaul 2000-06-13 08:25:31 EDT
The RedHat 6.2 installation fails with an anaconda error using the latest 
image files "boot-20000407.img" and "update-disk-20000419.img".

Install scenario.

HP Kayak XU (pentium II 300mhz)
64 meg memory

Currently running RedHat v6.1(cartman)which is the sole operating system.  
The system is configured with 7 partitions.  RedHat v6.2 is located on 
partion 7 and a local harddrive install method is being used.

Boot machine using boot-20000407.img
At boot prompt type "linux updates text"
Go through assorted screens choosing (in particular):
    1)  Local Harddrive install
    2)  Upgrade current version
Installer asks for "update-disk-20000419.img" and begins gathering 
installed packages

Anaconda errors out with:

line 299, in read_CompsFile
     comp, add Package(packages[1])
     File "/usr/lib/anaconda/comps.py"
line 46, in __getitem__
     return self_packages[item]
keyerror:  dip


"dip" appears to be the dip application found in the RedHat v6.2 
distribution /RedHat/base/comps file under "Dialup WorkStation".  This is 
according to virtual screen F3 (or was it F2?) that shows this file was 
being processed at the time of the error.  This file does have a reference 
to the application "dip" in it.

Dan McNaul
Comment 1 Brock Organ 2000-06-13 12:08:21 EDT
hmmm ... I am unable to reproduce this trying to upgrade from a minimal 6.1
install (both w/dip added & without dip) using the updates disks listed above on
our closest test lab hardware (HP kayak XAs) ... do you have your old 6.1
package list ...?
Comment 2 danmcnaul 2000-06-13 14:31:14 EDT
Created attachment 438 [details]
rpm -qai run of RedHat v6.1 installed components.  (updates applied)
Comment 3 danmcnaul 2000-06-13 14:41:17 EDT
In my previous message I've provided a gzip'd version of Install.list.  This 
file is the output of an "rpm -qai" command.  It shows all installed 
applications and their descriptions.  The last time I updated v6.1 
(with "updates") was on January 13, 2000.
Comment 4 Brock Organ 2000-08-17 11:54:17 EDT
Dan,

Thanks for attaching your rpm list ... unfortunately I could not reproduce your
problem for the following steps using our generic test lab hardware:

1) a 6.1 install installing only the packages specified in your attachment above
(using a kicstart file with the package list)
2) copied the 6.2 tree image to a local partition
3) booted using boot-20000407.img using "linux text updates"
4) specified hard drive install, inserted updates disk (update-20000419.img)
5) selected "Upgrade" option, chose defaults
6) upgrade completed successfully

I would be interested to know if you could reproduce the above problem again on
your machine, or if it was a one-time spurious event ... also, maybe my steps
differed from what you did ... :)
Comment 5 Brock Organ 2000-08-22 17:20:57 EDT
Please reopen if you are still having this trouble, or if I misdiagnosed your
problem ... thanks for the report!